diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-01-30 01:38:08 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-02-01 17:07:32 -0500 |
commit | 86d9d577b75143acb21d104e37221fa7bad73e50 (patch) | |
tree | 42db1d358b39af5f9d8b4aa0dc7071b64511faa9 /recipes-ti | |
parent | 4260a7351187ccc63e4744554ff0780b857785fe (diff) | |
download | meta-ti-86d9d577b75143acb21d104e37221fa7bad73e50.tar.gz |
netapi: Only build binaries relevent to the machine
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/netapi/netapi-test_git.bb | 4 | ||||
-rw-r--r-- | recipes-ti/netapi/netapi.inc | 9 | ||||
-rw-r--r-- | recipes-ti/netapi/netapi_git.bb | 4 |
3 files changed, 10 insertions, 7 deletions
diff --git a/recipes-ti/netapi/netapi-test_git.bb b/recipes-ti/netapi/netapi-test_git.bb index 1347d346..3b7825c9 100644 --- a/recipes-ti/netapi/netapi-test_git.bb +++ b/recipes-ti/netapi/netapi-test_git.bb | |||
@@ -1,10 +1,10 @@ | |||
1 | DESCRIPTION = "Provides test and application binaries using NETAPI module" | 1 | DESCRIPTION = "Provides test and application binaries using NETAPI module" |
2 | COMPATIBLE_MACHINE = "keystone" | 2 | |
3 | DEPENDS = "netapi ipsecmgr" | 3 | DEPENDS = "netapi ipsecmgr" |
4 | 4 | ||
5 | include netapi.inc | 5 | include netapi.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
8 | 8 | ||
9 | EXTRA_OEMAKE = "PDK_INSTALL_PATH=${STAGING_INCDIR}" | 9 | EXTRA_OEMAKE = "PDK_INSTALL_PATH=${STAGING_INCDIR}" |
10 | 10 | ||
diff --git a/recipes-ti/netapi/netapi.inc b/recipes-ti/netapi/netapi.inc index e497b1a0..0e7b04b8 100644 --- a/recipes-ti/netapi/netapi.inc +++ b/recipes-ti/netapi/netapi.inc | |||
@@ -1,15 +1,20 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING.txt;md5=f2b4f162358b1ffaf3f2307287ca2074" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING.txt;md5=f2b4f162358b1ffaf3f2307287ca2074" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "keystone" | ||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
4 | BRANCH = "master" | 7 | BRANCH = "master" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/netapi.git;protocol=git;branch=${BRANCH}" | 8 | SRC_URI = "git://git.ti.com/keystone-rtos/netapi.git;protocol=git;branch=${BRANCH}" |
6 | 9 | ||
7 | # Below Commit ID corresponds to "DEV.NETAPI.01.01.00.06" | 10 | # Below Commit ID corresponds to "DEV.NETAPI.01.01.00.06" |
8 | SRCREV = "8180b61615965954eaaedc26053f9a8939d9a273" | 11 | SRCREV = "8180b61615965954eaaedc26053f9a8939d9a273" |
9 | PV = "01.01.00.06" | 12 | PV = "01.01.00.06" |
10 | INC_PR = "r2" | 13 | INC_PR = "r3" |
11 | 14 | ||
12 | DEVICELIST = "k2h k2k k2l k2e" | 15 | DEVICELIST_k2hk-evm = "k2h k2k" |
16 | DEVICELIST_k2l-evm = "k2l" | ||
17 | DEVICELIST_k2e-evm = "k2e" | ||
13 | 18 | ||
14 | CHOICELIST = "yes no" | 19 | CHOICELIST = "yes no" |
15 | 20 | ||
diff --git a/recipes-ti/netapi/netapi_git.bb b/recipes-ti/netapi/netapi_git.bb index 298a86fe..4427ecc2 100644 --- a/recipes-ti/netapi/netapi_git.bb +++ b/recipes-ti/netapi/netapi_git.bb | |||
@@ -1,12 +1,10 @@ | |||
1 | DESCRIPTION = "Provides NETAPI module: TI user space network library" | 1 | DESCRIPTION = "Provides NETAPI module: TI user space network library" |
2 | 2 | ||
3 | COMPATIBLE_MACHINE = "keystone" | ||
4 | |||
5 | DEPENDS = "common-csl-ip rm-lld qmss-lld cppi-lld sa-lld hplib pktlib nwal-lld" | 3 | DEPENDS = "common-csl-ip rm-lld qmss-lld cppi-lld sa-lld hplib pktlib nwal-lld" |
6 | 4 | ||
7 | include netapi.inc | 5 | include netapi.inc |
8 | 6 | ||
9 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
10 | 8 | ||
11 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" |
12 | 10 | ||