summaryrefslogtreecommitdiffstats
path: root/recipes-ti/netapi/netapi-test_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-27 00:08:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-26 14:04:22 -0500
commit6356441620e29db519a0e4d41af4c9ea8b1a9056 (patch)
tree60063e234e5865e404a0da377f8f499cc7ac6b64 /recipes-ti/netapi/netapi-test_git.bb
parentb490d090a1bb1f7fd0f4ecc507bb4518167ba72d (diff)
downloadmeta-ti-6356441620e29db519a0e4d41af4c9ea8b1a9056.tar.gz
netapi: Add recipe for NETAPI module
- Provide TI user space network library and test code - Supports k2h, k2k, k2l & k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/netapi/netapi-test_git.bb')
-rw-r--r--recipes-ti/netapi/netapi-test_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-ti/netapi/netapi-test_git.bb b/recipes-ti/netapi/netapi-test_git.bb
new file mode 100644
index 00000000..9d49c294
--- /dev/null
+++ b/recipes-ti/netapi/netapi-test_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Provides test and application binaries using NETAPI module"
2COMPATIBLE_MACHINE = "keystone"
3DEPENDS = "netapi ipsecmgr"
4
5include netapi.inc
6
7EXTRA_OEMAKE = "PDK_INSTALL_PATH=${STAGING_INCDIR}"
8
9do_compile () {
10# Build the netapi binaries
11 for device in ${DEVICELIST}
12 do
13 for choice in ${CHOICELIST}
14 do
15 oe_runmake -f makefile_armv7 tests NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
16 USEDYNAMIC_LIB="$choice" DEVICE="$device"
17 done
18
19# Now build the netapi appplications
20 cd ${S}/applications/ipsec_offload/ipsecmgr/build
21 oe_runmake clean NETAPI_SRC_DIR=${S} DEVICE="$device"
22 oe_runmake app NETAPI_SRC_DIR=${S} DEVICE="$device"
23
24 cd ${S}/applications/ipsec_offload/config-app/build
25 oe_runmake clean DEVICE="$device"
26 oe_runmake app DEVICE="$device"
27 cd ${S}
28 done
29}
30
31do_install () {
32 for device in ${DEVICELIST}
33 do
34 oe_runmake -f makefile_armv7 installbin INSTALL_INC_BASE_DIR=${D}/${includedir} \
35 INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} \
36 SYSCONFDIR=${D}${sysconfdir} DEVICE="$device"
37
38 cd ${S}/applications/ipsec_offload/ipsecmgr/build
39 oe_runmake install \
40 INSTALL_BIN_BASE_DIR=${D}${bindir} SYSCONFDIR=${D}${sysconfdir} \
41 DEVICE="$device"
42
43 cd ${S}/applications/ipsec_offload/config-app/build
44 oe_runmake install \
45 INSTALL_BIN_BASE_DIR=${D}${bindir} SYSCONFDIR=${D}${sysconfdir} \
46 DEVICE="$device"
47 cd ${S}
48 done
49}