summaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-16 18:20:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-21 15:15:14 -0500
commita9fe62d130146ed94dc248f35c563c1e76206517 (patch)
tree82112da40dab180b6325a5a0749b29f51c728064 /recipes-ti/multiprocmgr
parent73d028e699ad28120e83e93d5da596e9f05f4420 (diff)
downloadmeta-ti-a9fe62d130146ed94dc248f35c563c1e76206517.tar.gz
multiprocmgr: Update to new version of MPM 2.0.1.7
- Recipe split into main and test recipes. - Added dependency on mpm-transport & libdaemon & syslog-ng - Added startup scripts for daemon - Removed PR Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb18
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr.inc14
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb34
3 files changed, 55 insertions, 11 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
new file mode 100644
index 00000000..b05cd44e
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "TI Multiproc Manager test code"
2
3include multiprocmgr.inc
4
5DEPENDS = "multiprocmgr cmem"
6RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem"
7
8CC += "-I${STAGING_KERNEL_DIR}/include"
9
10do_compile() {
11 make -C ${S} test
12}
13
14do_install() {
15 install -d ${D}${bindir}/
16 install -c -m 755 ${S}/test/filetestdemo/host/bin/demo_filetest ${D}${bindir}/mpm_demo_filetest
17 install -c -m 755 ${S}/test/sync_test/host/bin/sync_test ${D}${bindir}/mpm_sync_test
18}
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc
new file mode 100644
index 00000000..26c89590
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr.inc
@@ -0,0 +1,14 @@
1HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/multi-proc-manager.git"
2LICENSE = "BSD-3-Clause & MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4"
4SECTION = "console"
5COMPATIBLE_MACHINE = "keystone"
6
7BRANCH = "master"
8# The following commits correspond to DEV.MPM-2.00.01.07
9SRCREV = "b79e1cdaed78014569d82cf2f748d3f5f91623ee"
10PV = "2.0.1.7"
11
12SRC_URI = "git://git.ti.com/keystone-linux/multi-proc-manager.git;protocol=git;branch=${BRANCH}"
13
14S = "${WORKDIR}/git"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index 3f2e52c6..e1c4f2fd 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -1,20 +1,32 @@
1DESCRIPTION = "TI Multiproc Manager for KeyStone II" 1DESCRIPTION = "TI Multiproc Manager for KeyStone II"
2HOMEPAGE = "http://gtgit01.gt.design.ti.com/git/?p=projects/multiprocmgr.git;a=summary" 2SUMMARY = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3LICENSE = "BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4"
5SECTION = "console"
6COMPATIBLE_MACHINE = "keystone"
7 3
8PR = "r1" 4include multiprocmgr.inc
9 5
10BRANCH ?= "master" 6DEPENDS = "mpm-transport libdaemon"
11SRCREV = "8a97fb5c2c06d5f02d30106629f27fe0ca8a4f95" 7RDEPENDS_${PN} = "syslog-ng"
12 8
13SRC_URI = "git://gtgit01.gt.design.ti.com/git/projects/multiprocmgr.git;protocol=git;branch=${BRANCH}"
14 9
15S = "${WORKDIR}/git" 10CC += "-I${STAGING_KERNEL_DIR}/include"
11
12INITSCRIPT_NAME = "mpmsrv-daemon.sh"
13INITSCRIPT_PARAMS = "defaults 10"
14
15inherit update-rc.d
16 16
17do_install() { 17do_install() {
18 install -d ${D}${bindir}/ 18 install -d ${D}${bindir}/
19 install -c -m 755 ${S}/mpmsrv ${D}${bindir}/mpmsrv 19 install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv
20 install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl
21
22 install -d ${D}${sysconfdir}/init.d/
23 install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
24 install -d ${D}${sysconfdir}/mpm/
25 install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh
26
27 install -d ${D}${includedir}/
28 install -c -m 755 ${S}/include/* ${D}${includedir}/
29
30 install -d ${D}${libdir}/
31 cp -a ${S}/lib/* ${D}${libdir}/
20} 32}