summaryrefslogtreecommitdiffstats
path: root/recipes-ti/matrix
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-11 17:34:10 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-11 17:34:10 +0200
commit343b48322ddfe8ca72c056804b350057b080fa47 (patch)
tree76086dbe5b1040a14ed41685a74c8ac776498487 /recipes-ti/matrix
parent7bab703f4ac28a1982eb9b16eea97330579404c6 (diff)
downloadmeta-ti-343b48322ddfe8ca72c056804b350057b080fa47.tar.gz
Matrix 2.0: initial add
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/matrix')
-rw-r--r--recipes-ti/matrix/matrix-gui-3d-demos_1.0.bb20
-rw-r--r--recipes-ti/matrix/matrix-gui-apps.inc40
-rw-r--r--recipes-ti/matrix/matrix-gui-clocks_1.0.bb37
-rw-r--r--recipes-ti/matrix/matrix-gui-coming-soon_1.0.bb19
-rw-r--r--recipes-ti/matrix/matrix-gui-crypto-demos_1.0.bb22
-rw-r--r--recipes-ti/matrix/matrix-gui-display-control_1.0.bb22
-rw-r--r--recipes-ti/matrix/matrix-gui-paths.inc2
-rw-r--r--recipes-ti/matrix/matrix-gui-pm-demos_1.0.bb22
-rw-r--r--recipes-ti/matrix/matrix-gui-qt4-demos_1.0.bb22
-rw-r--r--recipes-ti/matrix/matrix-gui-submenus_1.0.bb97
-rw-r--r--recipes-ti/matrix/matrix-gui-wifi-demos_1.0.bb22
-rw-r--r--recipes-ti/matrix/matrix-gui/init63
-rw-r--r--recipes-ti/matrix/matrix-gui_2.0.bb39
13 files changed, 427 insertions, 0 deletions
diff --git a/recipes-ti/matrix/matrix-gui-3d-demos_1.0.bb b/recipes-ti/matrix/matrix-gui-3d-demos_1.0.bb
new file mode 100644
index 00000000..c653c6fc
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-3d-demos_1.0.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "3D demo descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/603/5030/3ddemos_1.0.tar.gz"
9
10S = ${WORKDIR}/3ddemos
11
12require matrix-gui-apps.inc
13
14# Make sure 3D submenu has been installed
15RDEPENDS += matrix-gui-submenus-3d
16
17FILES_${PN} += "${MATRIX_BASE_DIR}/*"
18
19SRC_URI[md5sum] = "998363dbabea3724c4c3283a480cdb60"
20SRC_URI[sha256sum] = "aab5890dffe4e9f36f78a64ec16e7221649bb61ef1ceee2e1246cd666d197268"
diff --git a/recipes-ti/matrix/matrix-gui-apps.inc b/recipes-ti/matrix/matrix-gui-apps.inc
new file mode 100644
index 00000000..9449c062
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-apps.inc
@@ -0,0 +1,40 @@
1require matrix-gui-paths.inc
2
3MATRIX_FILES_DIR ?= ${S}
4
5# Append a generic function to the do_install step that will look in the
6# MATRIX_FILES_DIR for .desktop files and then:
7# 1. Install all non-script files into the MATRIX_APP_DIR
8# 2. Install all script files into ${bindir}
9do_install_append(){
10 cd ${MATRIX_FILES_DIR}
11 applist=`find . -name "*.desktop"`
12
13 for app in $applist
14 do
15 appdir=`dirname $app`
16 install -d ${D}${MATRIX_APP_DIR}/$appdir
17
18 # Get the non-script files which are the matrix metadata
19 matrix_apps=`find $appdir -type f ! -name "*\.sh"`
20 for m in $matrix_apps
21 do
22 install -m 0644 ${MATRIX_FILES_DIR}/$m ${D}${MATRIX_APP_DIR}/$appdir/
23 done
24
25 # Put the script files as executables in ${bindir}
26 scripts=`find $appdir -type f -name "*\.sh"`
27 for s in $scripts
28 do
29 if [ ! -d ${D}/${bindir} ]
30 then
31 install -d ${D}${bindir}
32 fi
33 install -m 0755 ${MATRIX_FILES_DIR}/$s ${D}${bindir}/
34 done
35 done
36
37 # Go back to the directory we started from in case there are
38 # other appends.
39 cd -
40}
diff --git a/recipes-ti/matrix/matrix-gui-clocks_1.0.bb b/recipes-ti/matrix/matrix-gui-clocks_1.0.bb
new file mode 100644
index 00000000..2b5c1b3f
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-clocks_1.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Clock setting descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/612/5031/clocks_1.0.tar.gz"
11
12S = ${WORKDIR}/clocks
13
14require matrix-gui-apps.inc
15
16# Make sure power submenu has been installed
17RDEPENDS += matrix-gui-submenus-power
18
19# Break out the individual files into separate packages. That way only the
20# clocks supported for each device can be installed. Prepend the list so
21# that we can get the files in ${bindir} first
22PACKAGES =+ "${PN}-300mhz ${PN}-600mhz ${PN}-800mhz ${PN}-1ghz"
23
24# Split the matrix files by clock
25FILES_${PN}-300mhz += "${MATRIX_APP_DIR}/power_set_300mhz/*"
26FILES_${PN}-600mhz += "${MATRIX_APP_DIR}/power_set_600mhz/*"
27FILES_${PN}-800mhz += "${MATRIX_APP_DIR}/power_set_800mhz/*"
28FILES_${PN}-1ghz += "${MATRIX_APP_DIR}/power_set_1ghz/*"
29
30# Split the ${bindir} files by clock
31FILES_${PN}-300mhz += "${bindir}/setopp2.sh"
32FILES_${PN}-600mhz += "${bindir}/setopp3.sh"
33FILES_${PN}-800mhz += "${bindir}/setopp4.sh"
34FILES_${PN}-1ghz += "${bindir}/setopp1.sh"
35
36SRC_URI[md5sum] = "9e76951feab2ecd9334e9c890426500f"
37SRC_URI[sha256sum] = "96dc90fffe45fc4bb499215f57c416d16ff874290d6b2f16b9e2fdbcb9c18cbe"
diff --git a/recipes-ti/matrix/matrix-gui-coming-soon_1.0.bb b/recipes-ti/matrix/matrix-gui-coming-soon_1.0.bb
new file mode 100644
index 00000000..076388d4
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-coming-soon_1.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "coming soon descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/616/5029/comingsoon_1.0.tar.gz"
11
12S = ${WORKDIR}
13
14require matrix-gui-apps.inc
15
16FILES_${PN} += "${MATRIX_BASE_DIR}/*"
17
18SRC_URI[md5sum] = "04076ed62be226ffee3f3960237c47f8"
19SRC_URI[sha256sum] = "f00d24a506f39b92ba335479f902bdb97680df3502f81343be5baab45fd2bc95"
diff --git a/recipes-ti/matrix/matrix-gui-crypto-demos_1.0.bb b/recipes-ti/matrix/matrix-gui-crypto-demos_1.0.bb
new file mode 100644
index 00000000..11589b39
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-crypto-demos_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Cryptography demo descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/609/5033/cryptodemos_1.0.tar.gz"
11
12S = ${WORKDIR}/cryptodemos
13
14require matrix-gui-apps.inc
15
16# Make sure crypto submenu has been installed and openssl is available
17RDEPENDS += "matrix-gui-submenus-cryptos openssl"
18
19FILES_${PN} += "${MATRIX_BASE_DIR}/*"
20
21SRC_URI[md5sum] = "17a640f9d8a18694a67a8c2e473d1a2d"
22SRC_URI[sha256sum] = "9d1724e33dfe93a38fe70e517b3e3e0a641c993ebd5f56cc54317b351b3ba06a"
diff --git a/recipes-ti/matrix/matrix-gui-display-control_1.0.bb b/recipes-ti/matrix/matrix-gui-display-control_1.0.bb
new file mode 100644
index 00000000..72c7d62a
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-display-control_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Display control descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/611/5034/displaycontrol_1.0.tar.gz"
11
12S = ${WORKDIR}/displaycontrol
13
14require matrix-gui-apps.inc
15
16# Make sure display submenu has been installed
17RDEPENDS += matrix-gui-submenus-display
18
19FILES_${PN} += "${MATRIX_BASE_DIR}/*"
20
21SRC_URI[md5sum] = "65b45c9a55395c6a574ca720fc47c628"
22SRC_URI[sha256sum] = "e8b8dee2ddf66f96b0420988e7cd3220306168887f78043e5aa4497388e77798"
diff --git a/recipes-ti/matrix/matrix-gui-paths.inc b/recipes-ti/matrix/matrix-gui-paths.inc
new file mode 100644
index 00000000..b5ad8e02
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-paths.inc
@@ -0,0 +1,2 @@
1export MATRIX_BASE_DIR = "${datadir}/matrix-gui-2.0"
2export MATRIX_APP_DIR = "${MATRIX_BASE_DIR}/apps"
diff --git a/recipes-ti/matrix/matrix-gui-pm-demos_1.0.bb b/recipes-ti/matrix/matrix-gui-pm-demos_1.0.bb
new file mode 100644
index 00000000..f11ac940
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-pm-demos_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Power management demo descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/610/5035/pmdemos_1.0.tar.gz"
11
12S = ${WORKDIR}/pmdemos
13
14require matrix-gui-apps.inc
15
16# Make sure power submenu has been installed
17RDEPENDS += matrix-gui-submenus-power
18
19FILES_${PN} += "${MATRIX_BASE_DIR}/*"
20
21SRC_URI[md5sum] = "81ee5495fe155bad88a4ba3510bb18b9"
22SRC_URI[sha256sum] = "14c36da61466b384fd196769cf4a4344a9e62440fe3389f94d27575f29c319b3"
diff --git a/recipes-ti/matrix/matrix-gui-qt4-demos_1.0.bb b/recipes-ti/matrix/matrix-gui-qt4-demos_1.0.bb
new file mode 100644
index 00000000..fd941043
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-qt4-demos_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Qt4 demo descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/608/5036/qt4demos_1.0.tar.gz"
11
12S = ${WORKDIR}/qt4demos
13
14require matrix-gui-apps.inc
15
16# Make sure qt4 submenu has been installed
17RDEPENDS += matrix-gui-submenus-qt4
18
19FILES_${PN} += "${MATRIX_BASE_DIR}/*"
20
21SRC_URI[md5sum] = "49b65c4af67117ba70e0ddabfe486abe"
22SRC_URI[sha256sum] = "8367c539caf6902961db4b8f38b0fb1f05b7b105d5e7fd143c9503ca0c8a1df2"
diff --git a/recipes-ti/matrix/matrix-gui-submenus_1.0.bb b/recipes-ti/matrix/matrix-gui-submenus_1.0.bb
new file mode 100644
index 00000000..c62e5fb8
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-submenus_1.0.bb
@@ -0,0 +1,97 @@
1DESCRIPTION = "Submenu packages for Matrix GUI v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8require matrix-gui-paths.inc
9
10# These packages make submenus in matrix and are not architecture specific
11PACKAGE_ARCH = "all"
12
13# List of submenu tarballs to use. Each tarball contains a desktop file
14# and PNG graphic file for the submenu.
15SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/589/5037/arm.tar.gz;name=armtarball \
16 https://gforge.ti.com/gf/download/frsrelease/588/5038/3d.tar.gz;name=3dtarball \
17 https://gforge.ti.com/gf/download/frsrelease/591/5039/cryptos.tar.gz;name=cryptostarball \
18 https://gforge.ti.com/gf/download/frsrelease/592/5040/display.tar.gz;name=displaytarball \
19 https://gforge.ti.com/gf/download/frsrelease/593/5041/ethernet.tar.gz;name=ethernettarball \
20 https://gforge.ti.com/gf/download/frsrelease/594/5042/multimedia.tar.gz;name=multimediatarball \
21 https://gforge.ti.com/gf/download/frsrelease/595/5043/power.tar.gz;name=powertarball \
22 https://gforge.ti.com/gf/download/frsrelease/596/5044/pru.tar.gz;name=prutarball \
23 https://gforge.ti.com/gf/download/frsrelease/597/5045/qt4.tar.gz;name=qt4tarball \
24 https://gforge.ti.com/gf/download/frsrelease/598/5046/settings.tar.gz;name=settingstarball \
25 https://gforge.ti.com/gf/download/frsrelease/599/5047/usb.tar.gz;name=usbtarball \
26 https://gforge.ti.com/gf/download/frsrelease/600/5048/wifi.tar.gz;name=wifitarball \
27"
28
29S = ${WORKDIR}
30
31# List of submenus to build packages for
32SUBMENUS = "arm 3d cryptos display ethernet multimedia power pru qt4 settings usb wifi"
33
34do_install(){
35 install -d ${D}${MATRIX_APP_DIR}
36
37 for x in ${SUBMENUS}
38 do
39 cp -rf ${S}/$x ${D}${MATRIX_APP_DIR}/
40 done
41}
42
43PACKAGES += "${PN}-arm ${PN}-3d ${PN}-cryptos ${PN}-display ${PN}-ethernet ${PN}-multimedia ${PN}-power ${PN}-pru ${PN}-qt4 ${PN}-settings ${PN}-usb ${PN}-wifi"
44
45# All submenu packages should depend on matrix-gui being installed
46RDEPENDS += matrix-gui
47
48# Add the files for each submenu package
49FILES_${PN}-arm = "${MATRIX_APP_DIR}/arm/*"
50FILES_${PN}-3d = "${MATRIX_APP_DIR}/3d/*"
51FILES_${PN}-cryptos = "${MATRIX_APP_DIR}/cryptos/*"
52FILES_${PN}-display = "${MATRIX_APP_DIR}/display/*"
53FILES_${PN}-ethernet = "${MATRIX_APP_DIR}/ethernet/*"
54FILES_${PN}-multimedia = "${MATRIX_APP_DIR}/multimedia/*"
55FILES_${PN}-power = "${MATRIX_APP_DIR}/power/*"
56FILES_${PN}-pru = "${MATRIX_APP_DIR}/pru/*"
57FILES_${PN}-qt4 = "${MATRIX_APP_DIR}/qt4/*"
58FILES_${PN}-settings = "${MATRIX_APP_DIR}/settings/*"
59FILES_${PN}-usb = "${MATRIX_APP_DIR}/usb/*"
60FILES_${PN}-wifi = "${MATRIX_APP_DIR}/wifi/*"
61
62# checksums for the submenu tarballs
63SRC_URI[armtarball.md5sum] = "ed7d73441e0d85e84aa6df06d86e9d72"
64SRC_URI[armtarball.sha256um] = "99f9ccba0df1d8f1bfb78cf90eec8e64e961651ba6079e9c4bb21f8243d33ece"
65
66SRC_URI[3dtarball.md5sum] = "8aa161e1836e0efcf3db657f94137a34"
67SRC_URI[3dtarball.sha256um] = "b522065d288e49f50cbf1ee2c9deb76683161d82eb0429635bc66c4f26f235f1"
68
69SRC_URI[cryptostarball.md5sum] = "d1fbc3b575775557e3e150818d86373a"
70SRC_URI[cryptostarball.sha256um] = "f4c1645bf858dc157d4efae3ca66e437310294bfd564bdeb89c6609ae65cadf9"
71
72SRC_URI[displaytarball.md5sum] = "aa72fc22aa550b48ab32e28b2f8cbbcf"
73SRC_URI[displaytarball.sha256sum] = "593a7f91226b10b1f37fdf85c0d70c8aaf4a690df50ae364c422dbc2c586352b"
74
75SRC_URI[ethernettarball.md5sum] = "2a8afa6b2666d210eb9ac3c48dd173c0"
76SRC_URI[ethernettarball.sha256sum] = "1f78b81b043f4ed75b89697ad4609b5752a804300a094b279bc0391464c8af8d"
77
78SRC_URI[multimediatarball.md5sum] = "8ef64f7b252633d6b2f74561f047f874"
79SRC_URI[multimediatarball.sha256sum] = "e093c06b7bb40e51ab42ef1d896008d3ba3463629532bd0dcc1417368b73054b"
80
81SRC_URI[powertarball.md5sum] = "26ef7b4e83386a5a16a08fdb04e20047"
82SRC_URI[powertarball.sha256sum] = "87b3381cffeb2951ad7ffdff8df2661ad845303ffc850fa10caf8a9b35c09da5"
83
84SRC_URI[prutarball.md5sum] = "6f28ee2bc5de2bb9db035e4736f6e205"
85SRC_URI[prutarball.sha256sum] = "872fc89905fab81007274aa86cd43d822c71cf799bf7de92ac9e0394ced158d1"
86
87SRC_URI[qt4tarball.md5sum] = "f724ca0c58de81477583294078f8666e"
88SRC_URI[qt4tarball.sha256sum] = "75758cf90981c73603e728fd835f91b250978fb8141634f16b6e7b4ec62c08b1"
89
90SRC_URI[settingstarball.md5sum] = "a9de5dfa9cf007f7401d5768655fef15"
91SRC_URI[settingstarball.sha256sum] = "611f19671a2403f1d4f86ac46981d9297851572d867f4049d34b25c4831d2a0a"
92
93SRC_URI[usbtarball.md5sum] = "c03096c816724a3f3ae34a92b0c8729e"
94SRC_URI[usbtarball.sha256sum] = "384f733ef1b6808a29a0cfd102ab1ec766913fc88bfa587ee9fb46028835190a"
95
96SRC_URI[wifitarball.md5sum] = "f6ee538c77ac1ea7a502955e7e3cc624"
97SRC_URI[wifitarball.sha256sum] = "83edd8cf1c6efbfaa8c2e25b4a984ff6587aa7e379b833810452cb47ff5a6200"
diff --git a/recipes-ti/matrix/matrix-gui-wifi-demos_1.0.bb b/recipes-ti/matrix/matrix-gui-wifi-demos_1.0.bb
new file mode 100644
index 00000000..f33cba1b
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-wifi-demos_1.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Wifi demo descriptions for Matrix v2"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3LICENSE = "CC-BY-SA"
4PRIORITY = "optional"
5
6PR = "r0"
7
8PACKAGE_ARCH = "all"
9
10SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/617/5049/wifi_1.0.tar.gz"
11
12S = ${WORKDIR}/wifi
13
14require matrix-gui-apps.inc
15
16# Make sure wifi submenu has been installed
17RDEPENDS += matrix-gui-submenus-wifi
18
19FILES_${PN} += "${MATRIX_BASE_DIR}/*"
20
21SRC_URI[md5sum] = "10a57c18f0c6dcadb0371778a0959bbc"
22SRC_URI[sha256sum] = "91de898d12a2f980a454a8c3f14b8165fcbd15da3cf565ea5dc80f04ad982159"
diff --git a/recipes-ti/matrix/matrix-gui/init b/recipes-ti/matrix/matrix-gui/init
new file mode 100644
index 00000000..41f89cf2
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui/init
@@ -0,0 +1,63 @@
1#! /bin/sh
2
3matrixgui="/usr/bin/qtopia/demos/browser/browser"
4GUI_OPTS="-qws -nogui http://localhost:8080/index.html"
5PIDFILE="/var/run/matrix-gui-2.0.pid"
6
7test -x "$matrixgui" || exit 0
8
9export TSLIB_TSDEVICE=/dev/input/touchscreen0
10export QWS_MOUSE_PROTO=Tslib:/dev/input/touchscreen0
11
12case "$1" in
13 start)
14 chvt 4
15 if [ ! -f /etc/pointercal ] ; then
16 echo -n "Calibrating touchscreen (first time only)"
17 ts_calibrate
18 echo "."
19 fi
20
21 # Temporarily create the /dev/input/touchscreen0 symlink if it is
22 # not already present. On devices like am335x the driver does not
23 # report the right string in /sys/devices/platform/tsc/input/input0/modalias
24 # to match the regular expression in /etc/udev/rules.d/local.rules
25 # to have this symlink created automatically.
26 if [ ! -e /dev/input/touchscreen0 ]
27 then
28 # assume we are going to use event0
29 ln -s /dev/input/event0 /dev/input/touchscreen0
30 fi
31
32 if [ -e $PIDFILE ]; then
33 PIDDIR=/proc/$(cat $PIDFILE)
34 if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${matrixgui}" ]; then
35 echo "$DESC already started; not starting."
36 else
37 echo "Removing stale PID file $PIDFILE."
38 rm -f $PIDFILE
39 fi
40 fi
41
42 echo -n "Starting Matrix GUI application"
43 cd __MATRIX_BASE_DIR__
44 start-stop-daemon --start --quiet --background --exec node -- server.js
45 # Need to investigate how to make the second start-stop command wait
46 # until the start of node is done.
47 sleep 5
48 start-stop-daemon --start --quiet --background --exec $matrixgui -- $GUI_OPTS
49 pidof ${matrixgui} > $PIDFILE
50 echo "."
51 ;;
52
53 stop)
54 echo -n "Stopping Matrix GUI application"
55 start-stop-daemon --stop --quiet --pidfile /var/run/matrix-gui-2.0.pid
56 echo "."
57 ;;
58 *)
59 echo "Usage: /etc/init.d/matrix-gui-2.0 {start|stop}"
60 exit 1
61esac
62
63exit 0
diff --git a/recipes-ti/matrix/matrix-gui_2.0.bb b/recipes-ti/matrix/matrix-gui_2.0.bb
new file mode 100644
index 00000000..378a1f9e
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui_2.0.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Matrix GUI Application launcher"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix-gui-v2/"
3LICENSE = "BSD MIT Apache"
4SECTION = "multimedia"
5PRIORITY = "optional"
6
7PR = "r3"
8
9INITSCRIPT_NAME = "matrix-gui-2.0"
10INITSCRIPT_PARAMS = "defaults 99"
11
12PACKAGE_ARCH = "all"
13
14inherit update-rc.d
15
16BRANCH ?= "master"
17SRCREV = "c6db82baffcd96b20e67aa5cfdb4c0c98ef208b9"
18
19SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH} \
20 file://init"
21
22require matrix-gui-paths.inc
23
24S = "${WORKDIR}/git"
25
26do_install(){
27 install -d ${D}${MATRIX_BASE_DIR}
28 cp -rf ${S}/* ${D}${MATRIX_BASE_DIR}
29
30 # Set the proper path in the init script
31 sed -i -e s=__MATRIX_BASE_DIR__=${MATRIX_BASE_DIR}= ${WORKDIR}/init
32
33 install -d ${D}${sysconfdir}/init.d
34 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui-2.0
35}
36
37RDEPENDS_${PN} += nodejs
38
39FILES_${PN} += "${MATRIX_BASE_DIR}/*"