diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2014-10-08 18:06:20 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-10-08 13:33:18 -0400 |
commit | 0f2fed9a0c6534b31320bad0d423e8022bc2bdc2 (patch) | |
tree | 05af2d6ee33499b3f06e4c1c1734c253e1edec82 /recipes-ti/ipc/ti-ipc_git.bb | |
parent | aedc4d91bc5088ec6e6fe9d4de506503e201c6ca (diff) | |
download | meta-ti-0f2fed9a0c6534b31320bad0d423e8022bc2bdc2.tar.gz |
ti-ipc: Upgrade to IPC 3.30.00.09
* Added new recipe for latest IPC
* Removed older recipe versions
* Latest recipe points to IPC 3.30.00.09
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ti-ipc_git.bb')
-rw-r--r-- | recipes-ti/ipc/ti-ipc_git.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb new file mode 100644 index 00000000..185e58b8 --- /dev/null +++ b/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" | ||
2 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=abd112f156e5eb9b0f3e202e48747f9a" | ||
6 | |||
7 | DEPENDS += "virtual/kernel" | ||
8 | |||
9 | PV = "3.30.00.09" | ||
10 | |||
11 | # This is the first version of the 3.30.00.09 | ||
12 | # PR = "r0" | ||
13 | |||
14 | BRANCH = "master" | ||
15 | SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \ | ||
16 | file://tiipclad-daemon.sh \ | ||
17 | " | ||
18 | SRCREV = "595bc3e3bbb2e7ec12a8287145d8e3929291e59d" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
23 | |||
24 | PLATFORM = "UNKNOWN" | ||
25 | PLATFORM_omap5-evm = "OMAP54XX" | ||
26 | PLATFORM_dra7xx = "DRA7XX" | ||
27 | PLATFORM_keystone = "TCI6638" | ||
28 | |||
29 | DAEMON = "UNKNOWN" | ||
30 | DAEMON_omap5-evm = "lad_omap54xx_smp" | ||
31 | DAEMON_dra7xx = "lad_dra7xx" | ||
32 | DAEMON_keystone = "lad_tci6638" | ||
33 | |||
34 | inherit autotools pkgconfig update-rc.d | ||
35 | |||
36 | INITSCRIPT_NAME = "tiipclad-daemon.sh" | ||
37 | INITSCRIPT_PARAMS = "defaults 10" | ||
38 | |||
39 | EXTRA_OECONF += "PLATFORM=${PLATFORM} KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" | ||
40 | |||
41 | do_configure() { | ||
42 | oe_runconf | ||
43 | } | ||
44 | |||
45 | do_install_append() { | ||
46 | install -d ${D}${sysconfdir}/init.d/ | ||
47 | |||
48 | # Modify the tiipclad-daemon.sh script to point to the right | ||
49 | # lad daemon executable. | ||
50 | sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.sh | ||
51 | install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
52 | } | ||
53 | |||
54 | PACKAGES =+ "${PN}-test" | ||
55 | RDEPENDS_${PN}-test += "${PN}" | ||
56 | |||
57 | FILES_${PN}-test = " \ | ||
58 | ${bindir}/NameServerApp \ | ||
59 | ${bindir}/MessageQApp \ | ||
60 | ${bindir}/MessageQMulti \ | ||
61 | ${bindir}/ping_rpmsg" | ||
62 | |||