summaryrefslogtreecommitdiffstats
path: root/recipes-ti/engine-pkcs11
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-11 05:04:35 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-19 16:45:43 -0500
commit25b2d8a992e74a181d249895e6be32f9e2fef8e8 (patch)
treee6eb5979fed9e0f9c618c11fc79df58b68514d9b /recipes-ti/engine-pkcs11
parentdf0547480218a5f7688243010a769788703b7d85 (diff)
downloadmeta-ti-25b2d8a992e74a181d249895e6be32f9e2fef8e8.tar.gz
engine-pkcs11: Add recipe for PKCS11 engine
- Provides OpenSSL PKCS11 engine Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/engine-pkcs11')
-rw-r--r--recipes-ti/engine-pkcs11/engine-pkcs11_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-ti/engine-pkcs11/engine-pkcs11_git.bb b/recipes-ti/engine-pkcs11/engine-pkcs11_git.bb
new file mode 100644
index 00000000..226beaca
--- /dev/null
+++ b/recipes-ti/engine-pkcs11/engine-pkcs11_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "OpenSSL PKCS11 engine"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;startline=1;endline=26;md5=471dacb7f0586e35729f422b8098585f"
4SECTION = "libs"
5
6inherit autotools pkgconfig
7
8DEPENDS = "openssl libtool libp11"
9
10PV = "1.3.0.0"
11BRANCH="master"
12# Commit corresponds to DEV.ENGINE_PKCS11-01.03.00.00
13SRCREV = "0b14500b0ea8b37453b6d93aac02278465e7e732"
14
15SRC_URI = "git://git.ti.com/keystone-linux/engine-pkcs11.git;protocol=git;branch=${BRANCH}"
16S = "${WORKDIR}/git"
17
18FILES_${PN} += "${libdir}/engines/*.so*"
19FILES_${PN}-dbg += "${libdir}/engines/.debug"