summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb
diff options
context:
space:
mode:
authorSuraj Das <s-das@ti.com>2018-01-12 01:14:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-01-15 20:25:07 -0500
commit8bedfc18f1e3faf77fba4301991d4723259e01bf (patch)
tree4b6623da34ea5a63a09d69b75c9a5d131ae9aa2f /recipes-ti/devtools/ti-cgt-pru_2.2.1.bb
parentb8c6a1426e6301df1ab17de635e26cbb9e0f9949 (diff)
downloadmeta-ti-8bedfc18f1e3faf77fba4301991d4723259e01bf.tar.gz
ti-cgt-pru: update toolchain to 2.2.1 version
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools/ti-cgt-pru_2.2.1.bb')
-rw-r--r--recipes-ti/devtools/ti-cgt-pru_2.2.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb b/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb
new file mode 100644
index 00000000..8d3887e5
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt-pru_2.2.1.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "TI PRU Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
4
5LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.2.x_manifest.html;md5=e84b4022808f66b075095cb896747758"
6LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.2.x_manifest.html;md5=e84b4022808f66b075095cb896747758"
7
8require recipes-ti/includes/ti-paths.inc
9require recipes-ti/includes/ti-unpack.inc
10
11BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin"
12BINFILE_NAME = "cgt-pru-x86"
13TI_BIN_UNPK_ARGS = "--prefix ${S}"
14TI_BIN_UNPK_CMDS = ""
15
16BINFILE_class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh"
17BINFILE_NAME_class-target = "cgt-pru-arm"
18
19SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/PRU/${PV}/${BINFILE};name=${BINFILE_NAME}"
20
21SRC_URI[cgt-pru-x86.md5sum] = "749d75841eef7b465c7cb08beaa1d135"
22SRC_URI[cgt-pru-x86.sha256sum] = "7dc37fd689d1d506bf410d2a00af658b93a58d4bc10ac32c2210129dab617377"
23
24SRC_URI[cgt-pru-arm.md5sum] = "389eef56777e30e6dab337efca4af2bf"
25SRC_URI[cgt-pru-arm.sha256sum] = "b47a032f67cb3a3e5bea8ee3ed1908038f42938dd08e2ff72fc64f7aae2c1ff8"
26
27do_install() {
28 install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}
29 cp -r ${S}/ti-cgt-pru_${PV}/. \
30 ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/
31}
32
33do_install_class-target() {
34 ${WORKDIR}/${BINFILE} --prefix ${D}
35}
36
37FILES_${PN} += "${datadir}/ti/*"
38
39FILES_${PN}-dbg = "${TI_CGT_PRU_INSTALL_DIR_RECIPE}/bin/.debug \
40 ${TI_CGT_PRU_INSTALL_DIR_RECIPE}/lib/.debug \
41"
42
43INHIBIT_PACKAGE_STRIP = "1"
44INHIBIT_SYSROOT_STRIP = "1"
45INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
46
47INSANE_SKIP_${PN} += "arch staticdev already-stripped"
48
49BBCLASSEXTEND = "native nativesdk"