summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-22 00:05:28 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-06-02 05:40:31 +0000
commit126936191932bff10cecc56cd17e8745d67e3cc9 (patch)
tree772635c72b1885ec6b3bd2602b6fec55e0d22c84 /recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
parentc6d7d2b31afeda33ab5dfb70c86b367405d7fea1 (diff)
downloadmeta-ti-126936191932bff10cecc56cd17e8745d67e3cc9.tar.gz
gcc-arm, gcc-aarch64: upgrade baremetal gcc compilers to 9.2-2019.12
Overlay recipes from meta-arm/master to provide baremetal gcc 9.2-2019.12 Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb')
-rw-r--r--recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb b/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
deleted file mode 100644
index f474c87f..00000000
--- a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "Baremetal GCC for ARM"
2LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
3
4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=f77466c63f5787f4bd669c402aabe061"
5
6require recipes-ti/includes/ti-paths.inc
7
8SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/7-2018q2/gcc-arm-none-eabi-7-2018-q2-update-linux.tar.bz2;name=gcc-arm-none"
9
10SRC_URI[gcc-arm-none.md5sum] = "299ebd3f1c2c90930d28ab82e5d8d6c0"
11SRC_URI[gcc-arm-none.sha256sum] = "bb17109f0ee697254a5d4ae6e5e01440e3ea8f0277f2e8169bf95d07c7d5fe69"
12
13S = "${WORKDIR}/gcc-arm-none-eabi-7-2018-q2-update"
14
15# only x86_64 is supported
16COMPATIBLE_HOST = "x86_64.*-linux"
17COMPATIBLE_HOST_class-target = "null"
18
19do_install() {
20 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
21 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
22}
23
24FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"
25
26INSANE_SKIP_${PN} = "already-stripped libdir staticdev build-deps file-rdeps"
27INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
28
29BBCLASSEXTEND = "native nativesdk"