diff options
author | Joel A Fernandes <joelagnel@ti.com> | 2011-11-02 15:36:33 -0500 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 09:38:56 +0100 |
commit | 65f5df7cb842d1b7f788dafaedb0f1cd7d9f151d (patch) | |
tree | 06e146fa015f0df184e81e8c4985e8fff67581a4 /recipes-kernel | |
parent | d7c60e83697b7601592682b9d1a1de073f61f0ca (diff) | |
download | meta-ti-65f5df7cb842d1b7f788dafaedb0f1cd7d9f151d.tar.gz |
linux-ti335x-psp 3.1: Fix gpio1_6 pinmux
This change is required to get GPIO 1_6 working for bone test init purposes
These 2 lines were dropped from the original patch.
Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.1/0002-ARM-OMAP2-beaglebone-add-LED-support.patch | 22 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.1.bb | 2 |
2 files changed, 19 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0002-ARM-OMAP2-beaglebone-add-LED-support.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0002-ARM-OMAP2-beaglebone-add-LED-support.patch index c1e75600..68c7f15b 100644 --- a/recipes-kernel/linux/linux-ti33x-psp-3.1/0002-ARM-OMAP2-beaglebone-add-LED-support.patch +++ b/recipes-kernel/linux/linux-ti33x-psp-3.1/0002-ARM-OMAP2-beaglebone-add-LED-support.patch | |||
@@ -1,12 +1,13 @@ | |||
1 | From 3672d287f5382b102e02400298a00d6f8052dd9d Mon Sep 17 00:00:00 2001 | 1 | From 4df4ee83b31e09942932d67890d36ae116363ac1 Mon Sep 17 00:00:00 2001 |
2 | From: Koen Kooi <koen@dominion.thruhere.net> | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | Date: Wed, 2 Nov 2011 09:11:59 +0100 | 3 | Date: Wed, 2 Nov 2011 09:11:59 +0100 |
4 | Subject: [PATCH 2/3] ARM: OMAP2+: beaglebone: add LED support | 4 | Subject: [PATCH] ARM: OMAP2+: beaglebone: add LED support |
5 | 5 | ||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | 6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> |
7 | --- | 7 | --- |
8 | arch/arm/mach-omap2/board-am335xevm.c | 66 +++++++++++++++++++++++++++++++++ | 8 | arch/arm/mach-omap2/board-am335xevm.c | 66 +++++++++++++++++++++++++++++++++ |
9 | 1 files changed, 66 insertions(+), 0 deletions(-) | 9 | arch/arm/mach-omap2/mux33xx.c | 2 +- |
10 | 2 files changed, 67 insertions(+), 1 deletions(-) | ||
10 | 11 | ||
11 | diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c | 12 | diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c |
12 | index ee936e0..ecf4a76 100644 | 13 | index ee936e0..ecf4a76 100644 |
@@ -113,6 +114,19 @@ index ee936e0..ecf4a76 100644 | |||
113 | {NULL, 0, 0}, | 114 | {NULL, 0, 0}, |
114 | }; | 115 | }; |
115 | 116 | ||
117 | diff --git a/arch/arm/mach-omap2/mux33xx.c b/arch/arm/mach-omap2/mux33xx.c | ||
118 | index 0286c4f..f09e827 100644 | ||
119 | --- a/arch/arm/mach-omap2/mux33xx.c | ||
120 | +++ b/arch/arm/mach-omap2/mux33xx.c | ||
121 | @@ -49,7 +49,7 @@ static struct omap_mux __initdata am33xx_muxmodes[] = { | ||
122 | NULL, NULL, NULL, NULL), | ||
123 | _AM33XX_MUXENTRY(GPMC_AD6, 0, | ||
124 | "gpmc_ad6", "mmc1_dat6", NULL, NULL, | ||
125 | - NULL, NULL, NULL, NULL), | ||
126 | + NULL, NULL, NULL, "gpio1_6"), | ||
127 | _AM33XX_MUXENTRY(GPMC_AD7, 0, | ||
128 | "gpmc_ad7", "mmc1_dat7", NULL, NULL, | ||
129 | NULL, NULL, NULL, NULL), | ||
116 | -- | 130 | -- |
117 | 1.7.2.5 | 131 | 1.7.4.1 |
118 | 132 | ||
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb index faf74063..953b5749 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb | |||
@@ -11,7 +11,7 @@ MULTI_CONFIG_BASE_SUFFIX = "" | |||
11 | 11 | ||
12 | BRANCH = "v3.1-staging" | 12 | BRANCH = "v3.1-staging" |
13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" | 13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" |
14 | MACHINE_KERNEL_PR_append = "n+gitr${SRCREV}" | 14 | MACHINE_KERNEL_PR_append = "o+gitr${SRCREV}" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(ti33x)" | 16 | COMPATIBLE_MACHINE = "(ti33x)" |
17 | 17 | ||