summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-08-26 12:25:26 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-08-27 21:27:54 -0400
commit5a5d98c1ad6a456370d205b65c8dc65a64e23916 (patch)
tree260c47976b0839ec40a6437f103792b1ef42ee06 /recipes-kernel
parent7144d488e7ce068ce1c4618d593d26e0e29e7798 (diff)
downloadmeta-ti-5a5d98c1ad6a456370d205b65c8dc65a64e23916.tar.gz
linux-ti-staging/linux-ti-glsdk: adjust DTB handling to new syntax
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk_3.8.bb6
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.8.bb12
-rw-r--r--recipes-kernel/linux/linux-ti-staging_git.bb14
3 files changed, 16 insertions, 16 deletions
diff --git a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
index 9e3e4991..5fd17f83 100644
--- a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
+++ b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
@@ -9,8 +9,8 @@ inherit kernel
9require recipes-kernel/linux/linux-dtb.inc 9require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/setup-defconfig.inc 10require recipes-kernel/linux/setup-defconfig.inc
11 11
12KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts" 12KERNEL_DEVICETREE_omap5-evm = "omap5-sevm.dtb omap5-uevm.dtb"
13KERNEL_DEVICETREE_dra7xx-evm = "arch/arm/boot/dts/dra7-evm.dts" 13KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb"
14 14
15COMPATIBLE_MACHINE = "omap-a15" 15COMPATIBLE_MACHINE = "omap-a15"
16 16
@@ -24,7 +24,7 @@ SRCREV = "6076e6882d1d6a64b104e42e56a3eada36605cb3"
24PV = "3.8.13" 24PV = "3.8.13"
25 25
26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
27MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" 27MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}"
28 28
29SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-3-8-y-kernel.git;protocol=git;branch=${BRANCH} \ 29SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-3-8-y-kernel.git;protocol=git;branch=${BRANCH} \
30 file://defconfig \ 30 file://defconfig \
diff --git a/recipes-kernel/linux/linux-ti-staging_3.8.bb b/recipes-kernel/linux/linux-ti-staging_3.8.bb
index 29ffebc2..fd7b671b 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.8.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.8.bb
@@ -13,12 +13,12 @@ require recipes-kernel/linux/setup-defconfig.inc
13# on the target file system. 13# on the target file system.
14RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript" 14RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript"
15 15
16# Default is to package all dts files for ti33x devices unless building 16# Default is to package all dtb files for ti33x devices unless building
17# for the specific beaglebone machine. 17# for the specific beaglebone machine.
18KERNEL_DEVICETREE_ti33x = "arch/arm/boot/dts/am335x-evm.dts arch/arm/boot/dts/am335x-evmsk.dts arch/arm/boot/dts/am335x-bone.dts" 18KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb"
19KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts" 19KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb"
20KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts" 20KERNEL_DEVICETREE_omap5-evm = "omap5-sevm.dtb omap5-uevm.dtb"
21KERNEL_DEVICETREE_dra7xx-evm = "arch/arm/boot/dts/dra7-evm.dts" 21KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb"
22 22
23COMPATIBLE_MACHINE = "ti33x|omap-a15" 23COMPATIBLE_MACHINE = "ti33x|omap-a15"
24 24
@@ -31,7 +31,7 @@ SRCREV = "f3cb62a800ae37f17a3382b10d155ee02dbc83fc"
31PV = "3.8.13" 31PV = "3.8.13"
32 32
33# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 33# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
34MACHINE_KERNEL_PR_append = "f+gitr${SRCPV}" 34MACHINE_KERNEL_PR_append = "g+gitr${SRCPV}"
35 35
36SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 36SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
37 file://defconfig \ 37 file://defconfig \
diff --git a/recipes-kernel/linux/linux-ti-staging_git.bb b/recipes-kernel/linux/linux-ti-staging_git.bb
index cb59dbbc..7d84cc44 100644
--- a/recipes-kernel/linux/linux-ti-staging_git.bb
+++ b/recipes-kernel/linux/linux-ti-staging_git.bb
@@ -13,13 +13,13 @@ require recipes-kernel/linux/setup-defconfig.inc
13# on the target file system. 13# on the target file system.
14RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript" 14RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript"
15 15
16# Default is to package all dts files for ti33x devices unless building 16# Default is to package all dtb files for ti33x devices unless building
17# for the specific beaglebone machine. 17# for the specific beaglebone machine.
18KERNEL_DEVICETREE_ti33x = "arch/arm/boot/dts/am335x-evm.dts arch/arm/boot/dts/am335x-evmsk.dts arch/arm/boot/dts/am335x-bone.dts" 18KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb"
19KERNEL_DEVICETREE_am437x-evm = "arch/arm/boot/dts/am43x-epos-evm.dts" 19KERNEL_DEVICETREE_am437x-evm = "am43x-epos-evm.dtb"
20KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts" 20KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb"
21KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts" 21KERNEL_DEVICETREE_omap5-evm = "omap5-sevm.dtb omap5-uevm.dtb"
22KERNEL_DEVICETREE_dra7xx-evm = "arch/arm/boot/dts/dra7-evm.dts" 22KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb"
23 23
24KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 24KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
25 25
@@ -35,7 +35,7 @@ SRCREV = "b36f4be3de1b123d8601de062e7dbfc904f305fb"
35PV = "3.10+3.11-rc6" 35PV = "3.10+3.11-rc6"
36 36
37# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 37# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
38MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" 38MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
39 39
40SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 40SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
41 file://defconfig \ 41 file://defconfig \