diff options
author | Prabindh Sundareson <prabu@ti.com> | 2013-06-12 22:52:34 +0530 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-06-21 14:43:24 -0400 |
commit | adb1681db776d843bbb0d644557509a73b0b89d5 (patch) | |
tree | 100eae017fc7e004a387d575bda205cdad8dfbf7 /recipes-graphics | |
parent | a8c949d455f3eea62d661c143457f7d66d481f8e (diff) | |
download | meta-ti-adb1681db776d843bbb0d644557509a73b0b89d5.tar.gz |
libgles-omap3: Remove X11 related build and packaging
SGX530 driver for X11 is only buildable and testable standalone
with the pre-built X11 package provided with the Graphics SDK.
This patch removes X11 build from the default recipe, to enable
moving X11 build to a separate recipe.
This is part of a clean up of the Graphics recipe starting from
4.09.00.01 version of the Graphics SDK.
Signed-off-by: Prabindh Sundareson <prabu at ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/libgles/libgles-omap3-no-x.inc | 330 | ||||
-rw-r--r-- | recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb | 46 |
2 files changed, 332 insertions, 44 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3-no-x.inc b/recipes-graphics/libgles/libgles-omap3-no-x.inc new file mode 100644 index 00000000..31c5b8e3 --- /dev/null +++ b/recipes-graphics/libgles/libgles-omap3-no-x.inc | |||
@@ -0,0 +1,330 @@ | |||
1 | DESCRIPTION = "libGLES for the omap3" | ||
2 | LICENSE = "proprietary-binary" | ||
3 | # 'TSPA.txt' might not be the best file to md5sum | ||
4 | LIC_FILES_CHKSUM = "file://TSPA.txt;md5=c0d5d9c1e38b41677144c4e24d6ddee1" | ||
5 | |||
6 | PR = "r35" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(omap3|ti814x|ti816x|ti33x)" | ||
9 | |||
10 | PVR_INIT ?= "pvrsrvinit" | ||
11 | |||
12 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2" | ||
13 | |||
14 | RREPLACES_${PN} = "libegl libgles1 libgles2" | ||
15 | RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev" | ||
16 | RREPLACES_${PN}-dbg = "libegl-dbg" | ||
17 | |||
18 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ | ||
19 | file://cputype \ | ||
20 | file://rc.pvr \ | ||
21 | file://99-bufferclass.rules \ | ||
22 | " | ||
23 | |||
24 | S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}" | ||
25 | |||
26 | # Logic to unpack installjammer file | ||
27 | TI_BIN_UNPK_CMDS="Y: qY:workdir:Y" | ||
28 | require ../../recipes-ti/includes/ti-eula-unpack.inc | ||
29 | |||
30 | export BINLOCATION ?= "${S}/gfx_rel" | ||
31 | export ES2LOCATION ?= "${S}/gfx_rel_es2.x" | ||
32 | export ES3LOCATION ?= "${S}/gfx_rel_es3.x" | ||
33 | export ES5LOCATION ?= "${S}/gfx_rel_es5.x" | ||
34 | export ES6LOCATION ?= "${S}/gfx_rel_es6.x" | ||
35 | export ES8LOCATION ?= "${S}/gfx_rel_es8.x" | ||
36 | |||
37 | LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_FRONTWSEGL.so.1" | ||
38 | |||
39 | do_configure() { | ||
40 | # Attempt to fix up the worst offenders for file permissions | ||
41 | for i in $(find ${S} -name "*.h") $(find ${S} -name "*.c") $(find ${S} -name "Make*") ; do | ||
42 | chmod 0644 $i | ||
43 | done | ||
44 | |||
45 | # Attempt to create proper library softlinks | ||
46 | for sofile in $(find ${S} -name "lib*Open*.so") $(find ${S} -name "lib*srv*.so") $(find ${S} -name "lib*gl*.so") $(find ${S} -name "libpvr*.so") $(find ${S} -name "lib*GL*.so"); do | ||
47 | if [ "$(readlink -n ${sofile})" = "" ] ; then | ||
48 | mv $sofile ${sofile}.${IMGPV} | ||
49 | ln -sf $(basename ${sofile}.${IMGPV}) ${sofile} | ||
50 | ln -sf $(basename ${sofile}.${IMGPV}) ${sofile}$(echo ${IMGPV} | awk -F. '{print "." $1}') | ||
51 | ln -sf $(basename ${sofile}.${IMGPV}) ${sofile}$(echo ${IMGPV} | awk -F. '{print "." $1 "." $2}') | ||
52 | fi | ||
53 | done | ||
54 | |||
55 | # Due to recursive make PLAT_* isn't always passed down correctly, so use sed to fix those | ||
56 | for mak in $(find ${S} -name "*.mak") ; do | ||
57 | sed -i -e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g $mak | ||
58 | done | ||
59 | |||
60 | # clear out old stuff | ||
61 | find Binaries/ | xargs rm -f || true | ||
62 | } | ||
63 | |||
64 | # Force in GNU_HASH and paths to libs | ||
65 | TARGET_CC_ARCH += " ${TARGET_LINK_HASH_STYLE} -Wl,-rpath-link,${BINLOCATION} -L${BINLOCATION} \ | ||
66 | -L${STAGING_DIR_TARGET}${libdir} -Wl,-rpath-link,${STAGING_DIR_TARGET}${libdir}" | ||
67 | PARALLEL_MAKE = "" | ||
68 | |||
69 | PLATFORM ?= "LinuxOMAP3" | ||
70 | |||
71 | do_compile() { | ||
72 | export TOOLCHAIN="${TOOLCHAIN_PATH}" | ||
73 | export PLAT_CC="${CC}" | ||
74 | export PLAT_CPP="${CXX}" | ||
75 | export PLAR_AR="${AR}" | ||
76 | |||
77 | mkdir -p ${S}/demos/raw | ||
78 | mkdir -p ${S}/trainingcourses/raw | ||
79 | |||
80 | # Rebuild demos | ||
81 | for demo in ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Demos/* ; do | ||
82 | cd $demo/OGLES/Build/LinuxGeneric | ||
83 | oe_runmake Common=1 PLATFORM=${PLATFORM} X11BUILD=0 | ||
84 | rm $demo/OGLES/Build/${PLATFORM}/Release*/*.o | ||
85 | |||
86 | install -m 0755 $demo/OGLES/Build/${PLATFORM}/ReleaseRaw/* ${S}/demos/raw || true | ||
87 | done | ||
88 | |||
89 | for demo in ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Demos/* ; do | ||
90 | cd $demo/OGLES2/Build/LinuxGeneric | ||
91 | oe_runmake Common=1 PLATFORM=${PLATFORM} X11BUILD=0 | ||
92 | rm -f $demo/OGLES2/Build/${PLATFORM}/Release*/*.o | ||
93 | |||
94 | install -m 0755 $demo/OGLES2/Build/${PLATFORM}/ReleaseRaw/* ${S}/demos/raw || true | ||
95 | done | ||
96 | |||
97 | find ${S} -name "*_org" -delete | ||
98 | |||
99 | # Build OGLES2 Trainingcourses | ||
100 | for training in ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/TrainingCourse/* ; do | ||
101 | if [ -e $training/OGLES2/Build/LinuxGeneric/Makefile ] ; then | ||
102 | cd $training/OGLES2/Build/LinuxGeneric | ||
103 | fi | ||
104 | |||
105 | if [ -e $training/OGLES2/Build/${PLATFORM}/Makefile ] ; then | ||
106 | cd $training/OGLES2/Build/${PLATFORM} | ||
107 | fi | ||
108 | |||
109 | oe_runmake Common=1 PLATFORM=${PLATFORM} X11BUILD=0 | ||
110 | rm -f $training/OGLES2/Build/${PLATFORM}/Release*/*.o | ||
111 | |||
112 | install -m 0755 $training/OGLES2/Build/${PLATFORM}/ReleaseRaw/* ${S}/trainingcourses/raw || true | ||
113 | done | ||
114 | |||
115 | } | ||
116 | |||
117 | do_install () { | ||
118 | install -d ${D}${libdir} | ||
119 | cp -pPR ${BINLOCATION}/*.so* ${D}${libdir} | ||
120 | rm ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so* | ||
121 | rm ${D}${libdir}/libsrv_um_dri.so* | ||
122 | rm ${D}${libdir}/pvr_drv.so* | ||
123 | |||
124 | install -m 0644 ${BINLOCATION}/*.a ${D}${libdir} | ||
125 | |||
126 | install -d ${D}${bindir}/ | ||
127 | install -m 0755 ${WORKDIR}/cputype ${D}${bindir}/ | ||
128 | |||
129 | install -m 0755 ${BINLOCATION}/*_test ${D}${bindir}/ | ||
130 | install -m 0755 ${BINLOCATION}/gl* ${D}${bindir}/ | ||
131 | install -m 0755 ${BINLOCATION}/${PVR_INIT} ${D}${bindir}/ | ||
132 | |||
133 | install -d ${D}${includedir} | ||
134 | cp -pPR ${S}/GFX_Linux_KM/include4 ${D}${includedir}/ | ||
135 | cp -pPR ${S}/GFX_Linux_KM/services4 ${D}${includedir}/ | ||
136 | |||
137 | cp -pPR ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Builds/OGLES2/Include/* ${D}${includedir}/ | ||
138 | cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/* ${D}${includedir}/ | ||
139 | cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/${PLATFORM}/Include/GLES/* ${D}${includedir}/GLES/ 2>/dev/null || true | ||
140 | cp -pPr ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Builds/OGLES2/${PLATFORM}/Include/GLES/* ${D}${includedir}/GLES2/ 2>/dev/null || true | ||
141 | cp -pPr ${S}/GFX_Linux_SDK/OVG/SDKPackage/Builds/OVG/Include/v* ${D}${includedir}/ 2>/dev/null || true | ||
142 | cp -pPr ${S}/GFX_Linux_SDK/OVG/SDKPackage/Builds/OVG/Include/V* ${D}${includedir}/ 2>/dev/null || true | ||
143 | cp -pPr ${S}/include/*.h ${D}${includedir} || true | ||
144 | cp -pPr ${S}/include/wsegl/*.h ${D}${includedir} || true | ||
145 | |||
146 | install -d ${D}${sysconfdir}/init.d/ | ||
147 | cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init | ||
148 | |||
149 | install -d ${D}${sysconfdir} | ||
150 | echo "[default]" > ${D}${sysconfdir}/powervr.ini | ||
151 | echo "WindowSystem=${LIBGLESWINDOWSYSTEM}" >> ${D}${sysconfdir}/powervr.ini | ||
152 | |||
153 | # The ES2.x, ES3.x, ES5.x and ES6.x CPUs have different SGX hardware, so we need to install multiple sets of userspace | ||
154 | |||
155 | install -d ${D}${libdir}/ES8.0 | ||
156 | install -d ${D}${libdir}/ES6.0 | ||
157 | install -d ${D}${libdir}/ES5.0 | ||
158 | install -d ${D}${libdir}/ES3.0 | ||
159 | install -d ${D}${libdir}/ES2.0 | ||
160 | |||
161 | install -d ${D}${bindir}/ES8.0 | ||
162 | install -d ${D}${bindir}/ES6.0 | ||
163 | install -d ${D}${bindir}/ES5.0 | ||
164 | install -d ${D}${bindir}/ES3.0 | ||
165 | install -d ${D}${bindir}/ES2.0 | ||
166 | |||
167 | shared_prog="eglinfo pvr2d_test ${PVR_INIT} services_test sgx_blit_test sgx_clipblit_test sgx_flip_test sgx_init_test sgx_render_flip_test" | ||
168 | raw_prog="gles1test1 gles2test1 ovg_unit_test" | ||
169 | |||
170 | for esrev in 2 3 5 6 8 ; do | ||
171 | ESLOCATION=$(eval echo $(echo \$\{ES${esrev}LOCATION\})) | ||
172 | if [ -e ${ESLOCATION} ] ; then | ||
173 | cp -pPR ${ESLOCATION}/lib*${IMGPV} ${ESLOCATION}/pvr_drv.so ${ESLOCATION}/*.a ${D}${libdir}/ES${esrev}.0/ | ||
174 | for esprog in $shared_prog $raw_prog ; do | ||
175 | install -m 0755 ${ESLOCATION}/$esprog ${D}${bindir}/ES${esrev}.0/ 2>/dev/null || true | ||
176 | done | ||
177 | fi | ||
178 | done | ||
179 | |||
180 | rm ${D}${bindir}/ES*/*.h ${D}${bindir}/ES*/pdsasm ${D}${bindir}/pdsasm -f || true | ||
181 | |||
182 | install -d ${D}${bindir}/SGX/demos/Raw/ | ||
183 | install -m 0755 ${S}/demos/raw/* ${D}${bindir}/SGX/demos/Raw/ | ||
184 | install -d ${D}${bindir}/SGX/trainingcourses/Raw 2>/dev/null || true | ||
185 | install -m 0755 ${S}/trainingcourses/raw/* ${D}${bindir}/SGX/trainingcourses/Raw/ 2>/dev/null || true | ||
186 | |||
187 | |||
188 | # Delete objects and linker scripts hidden between the headers | ||
189 | find ${D} -name "*.o" -delete | ||
190 | find ${D} -name "*.o.cmd" -delete | ||
191 | |||
192 | install -d ${D}${sysconfdir}/udev/rules.d | ||
193 | install -m 0644 ${WORKDIR}/99-bufferclass.rules ${D}${sysconfdir}/udev/rules.d/ | ||
194 | |||
195 | } | ||
196 | |||
197 | PACKAGES =+ "${PN}-rawdemos ${PN}-rawtrainingcourses ${PN}-tests" | ||
198 | # Package the base libraries per silicon revision | ||
199 | PACKAGES =+ "${PN}-es2 ${PN}-es3 ${PN}-es5 ${PN}-es6 ${PN}-es8" | ||
200 | RRECOMMENDS_${PN} += "${PN}-es2 ${PN}-es3 ${PN}-es5 ${PN}-es6 ${PN}-es8" | ||
201 | FILES_${PN}-es2 = "${libdir}/ES2*/* ${bindir}/ES2*/*" | ||
202 | FILES_${PN}-es3 = "${libdir}/ES3*/* ${bindir}/ES3*/*" | ||
203 | FILES_${PN}-es5 = "${libdir}/ES5*/* ${bindir}/ES5*/*" | ||
204 | FILES_${PN}-es6 = "${libdir}/ES6*/* ${bindir}/ES6*/*" | ||
205 | FILES_${PN}-es8 = "${libdir}/ES8*/* ${bindir}/ES8*/*" | ||
206 | |||
207 | # Stop shlib code from picking a subpackage | ||
208 | PRIVATE_LIBS_${PN}-es2 = "libGLESv2.so libIMGegl.so libsrv_um.so libOpenVG.so libpvr2d.so libsrv_init.so libEGL.so libsrv_um_dri.so libOpenVGU.so libglslcompiler.so libGLES_CM.so" | ||
209 | PRIVATE_LIBS_${PN}-es3 = "libGLESv2.so libIMGegl.so libsrv_um.so libOpenVG.so libpvr2d.so libsrv_init.so libEGL.so libsrv_um_dri.so libOpenVGU.so libglslcompiler.so libGLES_CM.so" | ||
210 | PRIVATE_LIBS_${PN}-es5 = "libGLESv2.so libIMGegl.so libsrv_um.so libOpenVG.so libpvr2d.so libsrv_init.so libEGL.so libsrv_um_dri.so libOpenVGU.so libglslcompiler.so libGLES_CM.so" | ||
211 | PRIVATE_LIBS_${PN}-es6 = "libGLESv2.so libIMGegl.so libsrv_um.so libOpenVG.so libpvr2d.so libsrv_init.so libEGL.so libsrv_um_dri.so libOpenVGU.so libglslcompiler.so libGLES_CM.so" | ||
212 | PRIVATE_LIBS_${PN}-es8 = "libGLESv2.so libIMGegl.so libsrv_um.so libOpenVG.so libpvr2d.so libsrv_init.so libEGL.so libsrv_um_dri.so libOpenVGU.so libglslcompiler.so libGLES_CM.so" | ||
213 | |||
214 | |||
215 | PACKAGES =+ "${PN}-blitwsegl ${PN}-flipwsegl ${PN}-frontwsegl ${PN}-linuxfbwsegl" | ||
216 | FILES_${PN}-blitwsegl = "${libdir}/libpvrPVR2D_BLITWSEGL.so.*" | ||
217 | FILES_${PN}-flipwsegl = "${libdir}/libpvrPVR2D_FLIPWSEGL.so.*" | ||
218 | FILES_${PN}-frontwsegl = "${libdir}/libpvrPVR2D_FRONTWSEGL.so.*" | ||
219 | FILES_${PN}-linuxfbwsegl = "${libdir}/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
220 | |||
221 | PACKAGES =+ "${PN}-blitwsegl-es2 ${PN}-blitwsegl-es3 ${PN}-blitwsegl-es5 ${PN}-blitwsegl-es6 ${PN}-blitwsegl-es8 ${PN}-flipwsegl-es2 ${PN}-flipwsegl-es3 ${PN}-flipwsegl-es5 ${PN}-flipwsegl-es6 ${PN}-flipwsegl-es8 ${PN}-frontwsegl-es2 ${PN}-frontwsegl-es3 ${PN}-frontwsegl-es5 ${PN}-frontwsegl-es6 ${PN}-frontwsegl-es8 ${PN}-linuxfbwsegl-es2 ${PN}-linuxfbwsegl-es3 ${PN}-linuxfbwsegl-es5 ${PN}-linuxfbwsegl-es6 ${PN}-linuxfbwsegl-es8" | ||
222 | |||
223 | FILES_${PN}-blitwsegl-es2 = "${libdir}/ES2*/libpvrPVR2D_BLITWSEGL.so.*" | ||
224 | FILES_${PN}-blitwsegl-es3 = "${libdir}/ES3*/libpvrPVR2D_BLITWSEGL.so.*" | ||
225 | FILES_${PN}-blitwsegl-es5 = "${libdir}/ES5*/libpvrPVR2D_BLITWSEGL.so.*" | ||
226 | FILES_${PN}-blitwsegl-es6 = "${libdir}/ES6*/libpvrPVR2D_BLITWSEGL.so.*" | ||
227 | FILES_${PN}-blitwsegl-es8 = "${libdir}/ES8*/libpvrPVR2D_BLITWSEGL.so.*" | ||
228 | RRECOMMENDS_${PN}-blitwsegl = " ${PN}-blitwsegl-es2 ${PN}-blitwsegl-es3 ${PN}-blitwsegl-es5 ${PN}-blitwsegl-es6 ${PN}-blitwsegl-es8" | ||
229 | |||
230 | FILES_${PN}-flipwsegl-es2 = "${libdir}/ES2*/libpvrPVR2D_FLIPWSEGL.so.*" | ||
231 | FILES_${PN}-flipwsegl-es3 = "${libdir}/ES3*/libpvrPVR2D_FLIPWSEGL.so.*" | ||
232 | FILES_${PN}-flipwsegl-es5 = "${libdir}/ES5*/libpvrPVR2D_FLIPWSEGL.so.*" | ||
233 | FILES_${PN}-flipwsegl-es6 = "${libdir}/ES6*/libpvrPVR2D_FLIPWSEGL.so.*" | ||
234 | FILES_${PN}-flipwsegl-es8 = "${libdir}/ES8*/libpvrPVR2D_FLIPWSEGL.so.*" | ||
235 | RRECOMMENDS_${PN}-flipwsegl = " ${PN}-flipwsegl-es2 ${PN}-flipwsegl-es3 ${PN}-flipwsegl-es5 ${PN}-flipwsegl-es6 ${PN}-flipwsegl-es8" | ||
236 | |||
237 | FILES_${PN}-frontwsegl-es2 = "${libdir}/ES2*/libpvrPVR2D_FRONTWSEGL.so.*" | ||
238 | FILES_${PN}-frontwsegl-es3 = "${libdir}/ES3*/libpvrPVR2D_FRONTWSEGL.so.*" | ||
239 | FILES_${PN}-frontwsegl-es5 = "${libdir}/ES5*/libpvrPVR2D_FRONTWSEGL.so.*" | ||
240 | FILES_${PN}-frontwsegl-es6 = "${libdir}/ES6*/libpvrPVR2D_FRONTWSEGL.so.*" | ||
241 | FILES_${PN}-frontwsegl-es8 = "${libdir}/ES8*/libpvrPVR2D_FRONTWSEGL.so.*" | ||
242 | RRECOMMENDS_${PN}-frontwsegl = " ${PN}-frontwsegl-es2 ${PN}-frontwsegl-es3 ${PN}-frontwsegl-es5 ${PN}-frontwsegl-es6 ${PN}-frontwsegl-es8" | ||
243 | |||
244 | FILES_${PN}-linuxfbwsegl-es2 = "${libdir}/ES2*/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
245 | FILES_${PN}-linuxfbwsegl-es3 = "${libdir}/ES3*/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
246 | FILES_${PN}-linuxfbwsegl-es5 = "${libdir}/ES5*/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
247 | FILES_${PN}-linuxfbwsegl-es6 = "${libdir}/ES6*/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
248 | FILES_${PN}-linuxfbwsegl-es8 = "${libdir}/ES8*/libpvrPVR2D_LINUXFBWSEGL.so.*" | ||
249 | RRECOMMENDS_${PN}-linuxfbwsegl = " ${PN}-linuxfbwsegl-es2 ${PN}-linuxfbwsegl-es3 ${PN}-linuxfbwsegl-es5 ${PN}-linuxfbwsegl-es6 ${PN}-linuxfbwsegl-es8" | ||
250 | |||
251 | CONFFILES_${PN} = "${sysconfdir}/powervr.ini" | ||
252 | |||
253 | FILES_${PN} = "${sysconfdir} ${libdir}/*.so* ${bindir}/${PVR_INIT} ${bindir}/cputype ${bindir}/*" | ||
254 | |||
255 | FILES_${PN}-tests = "${bindir}/*test*" | ||
256 | FILES_${PN}-dbg = "${libdir}/.debug/* ${bindir}/.debug/* \ | ||
257 | ${libdir}/ES*/.debug ${bindir}/*/.debug\ | ||
258 | ${bindir}/SGX/demos/*/.debug/* \ | ||
259 | ${bindir}/SGX/trainingcourses/*/.debug/* \ | ||
260 | " | ||
261 | |||
262 | FILES_${PN}-rawdemos = "${bindir}/SGX/demos/Raw/*" | ||
263 | |||
264 | FILES_${PN}-rawtrainingcourses = "${bindir}/SGX/trainingcourses/Raw/*" | ||
265 | |||
266 | # The libs need the kernel-modules | ||
267 | RRECOMMENDS_${PN} += "omap3-sgx-modules" | ||
268 | |||
269 | # The initscript calls fbset, cputype calls devmem2 | ||
270 | RDEPENDS_${PN} += "fbset devmem2" | ||
271 | |||
272 | #HACK! These are binaries, so we can't guarantee that LDFLAGS match :( | ||
273 | INSANE_SKIP_${PN} = "ldflags dev-so" | ||
274 | INSANE_SKIP_${PN}-es3 = "ldflags dev-so staticdev" | ||
275 | INSANE_SKIP_${PN}-es5 = "ldflags dev-so staticdev" | ||
276 | INSANE_SKIP_${PN}-es6 = "ldflags dev-so staticdev" | ||
277 | INSANE_SKIP_${PN}-es8 = "ldflags dev-so staticdev" | ||
278 | INSANE_SKIP_${PN}-rawdemos = "ldflags dev-so useless-rpaths" | ||
279 | INSANE_SKIP_${PN}-blitwsegl = "ldflags" | ||
280 | INSANE_SKIP_${PN}-blitwsegl-es3 = "ldflags" | ||
281 | INSANE_SKIP_${PN}-blitwsegl-es5 = "ldflags" | ||
282 | INSANE_SKIP_${PN}-blitwsegl-es6 = "ldflags" | ||
283 | INSANE_SKIP_${PN}-blitwsegl-es8 = "ldflags" | ||
284 | INSANE_SKIP_${PN}-flipwsegl = "ldflags" | ||
285 | INSANE_SKIP_${PN}-flipwsegl-es3 = "ldflags" | ||
286 | INSANE_SKIP_${PN}-flipwsegl-es5 = "ldflags" | ||
287 | INSANE_SKIP_${PN}-flipwsegl-es6 = "ldflags" | ||
288 | INSANE_SKIP_${PN}-flipwsegl-es8 = "ldflags" | ||
289 | INSANE_SKIP_${PN}-frontwsegl = "ldflags" | ||
290 | INSANE_SKIP_${PN}-frontwsegl-es3 = "ldflags" | ||
291 | INSANE_SKIP_${PN}-frontwsegl-es5 = "ldflags" | ||
292 | INSANE_SKIP_${PN}-frontwsegl-es6 = "ldflags" | ||
293 | INSANE_SKIP_${PN}-frontwsegl-es8 = "ldflags" | ||
294 | INSANE_SKIP_${PN}-linuxfbwsegl = "ldflags" | ||
295 | INSANE_SKIP_${PN}-linuxfbwsegl-es3 = "ldflags" | ||
296 | INSANE_SKIP_${PN}-linuxfbwsegl-es5 = "ldflags" | ||
297 | INSANE_SKIP_${PN}-linuxfbwsegl-es6 = "ldflags" | ||
298 | INSANE_SKIP_${PN}-linuxfbwsegl-es8 = "ldflags" | ||
299 | INSANE_SKIP_${PN}-tests = "ldflags" | ||
300 | |||
301 | # Quality control is really poor on these SDKs, so hack around the latest madness: | ||
302 | FILES_${PN} += "${libdir}/*.so " | ||
303 | FILES_${PN}-dev = "${includedir}" | ||
304 | |||
305 | inherit update-rc.d | ||
306 | |||
307 | INITSCRIPT_NAME = "pvr-init" | ||
308 | INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ." | ||
309 | |||
310 | # Append to update-rc.d postinst | ||
311 | pkg_postinst_${PN}_append() { | ||
312 | rm -f $D${sysconfdir}/powervr-esrev | ||
313 | |||
314 | } | ||
315 | |||
316 | pkg_postinst_${PN}-blitwsegl() { | ||
317 | rm -f $D${sysconfdir}/powervr-esrev | ||
318 | } | ||
319 | |||
320 | pkg_postinst_${PN}-flipwsegl() { | ||
321 | rm -f $D${sysconfdir}/powervr-esrev | ||
322 | } | ||
323 | |||
324 | pkg_postinst_${PN}-frontwsegl() { | ||
325 | rm -f $D${sysconfdir}/powervr-esrev | ||
326 | } | ||
327 | pkg_postinst_${PN}-linuxfbwsegl() { | ||
328 | rm -f $D${sysconfdir}/powervr-esrev | ||
329 | } | ||
330 | |||
diff --git a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb index 7c6f2316..b68b4c30 100644 --- a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | require libgles-omap3.inc | 1 | require libgles-omap3-no-x.inc |
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
@@ -23,8 +23,6 @@ TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}" | |||
23 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ | 23 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ |
24 | file://cputype \ | 24 | file://cputype \ |
25 | file://rc.pvr \ | 25 | file://rc.pvr \ |
26 | file://rc_dri.pvr \ | ||
27 | file://sample.desktop \ | ||
28 | file://99-bufferclass.rules \ | 26 | file://99-bufferclass.rules \ |
29 | " | 27 | " |
30 | SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d" | 28 | SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d" |
@@ -32,44 +30,4 @@ SRC_URI[sha256sum] = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249 | |||
32 | 30 | ||
33 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" | 31 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" |
34 | 32 | ||
35 | LIBGLESWINDOWSYSTEM ?= "${@base_contains('DISTRO_FEATURES', 'x11',"libpvrPVR2D_DRIWSEGL.so" ,"libpvrPVR2D_FRONTWSEGL.so.1", d)}" | 33 | LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_FRONTWSEGL.so.1" |
36 | |||
37 | do_configure_append() { | ||
38 | |||
39 | # Change PVR server's user mode library to point to DRI | ||
40 | for drifile in $(find ${S} -name "libsrv_um_dri.so"); do | ||
41 | if [ "$drifile" != "" ] | ||
42 | then | ||
43 | dir=$(dirname ${drifile}) | ||
44 | if [ "$SUPPORT_XORG" = "1" ] | ||
45 | then | ||
46 | mv ${dir}/libsrv_um_dri.so ${dir}/libsrv_um.so | ||
47 | else | ||
48 | rm -rf ${dir}/libsrv_um_dri.so | ||
49 | fi | ||
50 | fi | ||
51 | |||
52 | done | ||
53 | } | ||
54 | |||
55 | do_install_append() { | ||
56 | |||
57 | # In this version of the graphics SDK the following directories do not exist: | ||
58 | # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/pvr2d.h (doesn't exist) | ||
59 | # /GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/GLES/egltypes.h (doesn't exist) | ||
60 | # Therefore, need to copy these files manually at the only location that they do exist | ||
61 | cp -pPr ${S}/include/pvr2d/*.h ${D}${includedir} | ||
62 | cp -pPr ${S}/include/OGLES/GLES ${D}${includedir}/ | ||
63 | |||
64 | rm ${D}${sysconfdir}/init.d/pvr-init | ||
65 | |||
66 | if [ "$SUPPORT_XORG" = "1" ]; then | ||
67 | cp -pP ${WORKDIR}/rc_dri.pvr ${D}${sysconfdir}/init.d/pvr-init | ||
68 | else | ||
69 | cp -pP ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init | ||
70 | fi | ||
71 | |||
72 | } | ||
73 | |||
74 | RRECOMMENDS_${PN}-x11demos = "${PN}-driwsegl" | ||
75 | RRECOMMENDS_${PN}-x11trainingcourses = "${PN}-driwsegl" | ||