summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2013-10-24 11:17:08 +0530
committerDenys Dmytriyenko <denys@ti.com>2013-11-21 23:18:17 -0500
commit8ade2a489adf4f0594db7c26839e06fd3c2f74c8 (patch)
tree00a9d751779de97127fd2f2f292940b94aba0d48 /recipes-graphics
parent46e020df8eb4e9d025cf344ccc5ffa774be2f6c1 (diff)
downloadmeta-ti-8ade2a489adf4f0594db7c26839e06fd3c2f74c8.tar.gz
libgles: added OMAP5 libs for graphics acceleration
These libraries are not distributable in source and hence are available only as binary. They implement OpenGLES 1.x and OpenGLES 2.x accelerated using SGX 544-MP2 found in OMAP5 class of devices. Signed-off-by: Mrinmayee Hingolikar <mrinmayee@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.10.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.10.bb b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.10.bb
new file mode 100644
index 00000000..8a03cd29
--- /dev/null
+++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.10.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Userspace libraries for omap5 sgx"
2HOMEPAGE = "http://downloads.ti.com/dsps/dsps_public_sw/gfxsdk"
3LICENSE = "TSPA"
4LIC_FILES_CHKSUM = "file://OMAP5-Linux-Graphics-DDK-UM-Manifest.doc;md5=d280df8e94bb2e7b9251c8526078eeb8"
5
6COMPATIBLE_MACHINE = "omap-a15"
7
8INHIBIT_PACKAGE_STRIP = "1"
9
10SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/OMAP5_1_09_00_10//exports/${PN}-${PV}.tar.gz;protocol=http"
11
12PR = "r0"
13
14SRC_URI[md5sum] = "3cfb875de031098a4c1eeeaf4e442367"
15SRC_URI[sha256sum] = "20b849088c0fd3ee5dd6bad8ddf16fb2b3267aa053cf3488c762fbc72f22489a"
16
17S = "${WORKDIR}/${PN}-${PV}"
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}
22
23FILES_${PN} += "${libdir}/gbm/"
24
25INSANE_SKIP_${PN} = "useless-rpaths"
26INSANE_SKIP_${PN}-dev = "useless-rpaths"