diff options
author | Anand Balagopalakrishnan <anandb@ti.com> | 2019-06-19 17:56:02 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-06-20 14:36:16 +0000 |
commit | 4d7e50b26a24cd21fb68b443a593eb695d669909 (patch) | |
tree | 89f3d5852fb608f1ff334044a6e96837ac4ac980 /recipes-graphics | |
parent | fa2f8054d54592071b0ae92587f70f2232a006f2 (diff) | |
download | meta-ti-4d7e50b26a24cd21fb68b443a593eb695d669909.tar.gz |
ti-img-rogue-umlibs: add PowerVR Rogue GPU user mode libraries for J721E SoC
Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb new file mode 100644 index 00000000..63b6ee99 --- /dev/null +++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | DESCRIPTION = "Userspace libraries for PowerVR Rogue GPU on TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-umlibs" | ||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f" | ||
5 | |||
6 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
7 | COMPATIBLE_MACHINE = "j7-evm" | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | BRANCH = "linux/thud/k4.19/${PV}" | ||
12 | |||
13 | SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" | ||
14 | SRCREV = "4dccfbeffa6427a56bf63ab83af9d2140d95045b" | ||
15 | |||
16 | PVR_SOC ?= "j721e_linux" | ||
17 | PVR_BUILD ?= "release" | ||
18 | |||
19 | INITSCRIPT_NAME = "rc.pvr" | ||
20 | INITSCRIPT_PARAMS = "defaults 8" | ||
21 | |||
22 | inherit update-rc.d | ||
23 | |||
24 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2" | ||
25 | |||
26 | DEPENDS += "libdrm" | ||
27 | RDEPENDS_${PN} += "bash" | ||
28 | RDEPENDS_${PN} += "python-core" | ||
29 | RDEPENDS_${PN} += "ti-img-rogue-driver" | ||
30 | |||
31 | RPROVIDES_${PN} = "libegl libgles1 libgles2" | ||
32 | RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev" | ||
33 | RPROVIDES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
34 | |||
35 | RREPLACES_${PN} = "libegl libgles1 liblges2" | ||
36 | RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev" | ||
37 | RREPLACES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
38 | |||
39 | RCONFLICTS_${PN} = "libegl libgles1 libgles2" | ||
40 | RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev" | ||
41 | RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
42 | |||
43 | S = "${WORKDIR}/git" | ||
44 | |||
45 | do_install () { | ||
46 | oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} | ||
47 | chown -R root:root ${D} | ||
48 | } | ||
49 | |||
50 | FILES_${PN} += " ${base_libdir}/firmware/" | ||
51 | FILES_${PN} += " ${datadir}/" | ||
52 | |||
53 | INSANE_SKIP_${PN} += "ldflags arch already-stripped" | ||
54 | |||
55 | CLEANBROKEN = "1" | ||