summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgal
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-07-10 07:06:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-10 18:39:09 +0000
commita5ecd90543b0842555662ea92e129d78e6f8c08b (patch)
treee78c524c27bd0922dbe64879c84fa2405dd6e30e /recipes-graphics/libgal
parentf64a19d3e99027030decbf4ae9760f3a22a4e584 (diff)
downloadmeta-ti-a5ecd90543b0842555662ea92e129d78e6f8c08b.tar.gz
meta-ti: cleanup use of d.getVar()
1. drop use of True as second parameter, which is default, to align with master 2. there were instances of incorrectly passing 'd' as second parameter from previous conversion from bb.data.getVar() usage Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics/libgal')
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index 52df495d..dafaac1e 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -14,11 +14,11 @@ SRCREV = "c0afab259de59909cfe74c01f3f7fbaa147f94b5"
14 14
15# There's only hardfp version available 15# There's only hardfp version available
16python __anonymous() { 16python __anonymous() {
17 tunes = d.getVar("TUNE_FEATURES", d, 1) 17 tunes = d.getVar("TUNE_FEATURES")
18 if not tunes: 18 if not tunes:
19 return 19 return
20 pkgn = d.getVar("PN", d, 1) 20 pkgn = d.getVar("PN")
21 pkgv = d.getVar("PV", d, 1) 21 pkgv = d.getVar("PV")
22 if "callconvention-hard" not in tunes: 22 if "callconvention-hard" not in tunes:
23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))