summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /recipes-core
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/eudev/firmware.rules3
-rw-r--r--recipes-core/udev/eudev/omap-tty.rules17
-rw-r--r--recipes-core/udev/eudev_%.bbappend13
3 files changed, 0 insertions, 33 deletions
diff --git a/recipes-core/udev/eudev/firmware.rules b/recipes-core/udev/eudev/firmware.rules
deleted file mode 100644
index f7a08ce9..00000000
--- a/recipes-core/udev/eudev/firmware.rules
+++ /dev/null
@@ -1,3 +0,0 @@
1# stub for immediately telling the kernel that userspace firmware loading
2# failed; necessary to avoid long timeouts with CONFIG_FW_LOADER_USER_HELPER=y
3SUBSYSTEM=="firmware", ACTION=="add", ATTR{loading}="-1"
diff --git a/recipes-core/udev/eudev/omap-tty.rules b/recipes-core/udev/eudev/omap-tty.rules
deleted file mode 100644
index 989d60f8..00000000
--- a/recipes-core/udev/eudev/omap-tty.rules
+++ /dev/null
@@ -1,17 +0,0 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# Backward compatibility with old OMAP UART-style ttyO0 naming
17SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n"
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
deleted file mode 100644
index ddb1e75d..00000000
--- a/recipes-core/udev/eudev_%.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3SRC_URI:append:ti-soc = " \
4 file://omap-tty.rules \
5 file://firmware.rules \
6"
7
8PR:append:ti-soc = ".3"
9
10do_install:append:ti-soc() {
11 install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/
12 install -m 0644 ${WORKDIR}/firmware.rules ${D}${sysconfdir}/udev/rules.d/
13}