diff options
author | Denys Dmytriyenko <denys@ti.com> | 2017-11-11 04:25:55 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-11-13 11:48:42 -0500 |
commit | e3b3c89b9163f16a5aa652d44fe337fa337e48a2 (patch) | |
tree | 36ec694fd7d57158a7caf177da22425eda6e8afa /recipes-connectivity/wl18xx-target-scripts | |
parent | 98e1dc1bed14e9685e7f6306469b36be109fb318 (diff) | |
download | meta-ti-e3b3c89b9163f16a5aa652d44fe337fa337e48a2.tar.gz |
wl18xx-target-scripts: replace /system/bin/sh with /bin/sh in one script
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-connectivity/wl18xx-target-scripts')
2 files changed, 29 insertions, 2 deletions
diff --git a/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts/0001-print_stat.sh-replace-system-bin-sh-with-bin-sh.patch b/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts/0001-print_stat.sh-replace-system-bin-sh-with-bin-sh.patch new file mode 100644 index 00000000..c0719e34 --- /dev/null +++ b/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts/0001-print_stat.sh-replace-system-bin-sh-with-bin-sh.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | From ba1ac3862c8c3b2dbb615dc342b7fb1eaa96900f Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Fri, 10 Nov 2017 17:02:39 -0500 | ||
4 | Subject: [PATCH] print_stat.sh: replace /system/bin/sh with /bin/sh | ||
5 | |||
6 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
7 | --- | ||
8 | testing/print_stat.sh | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/testing/print_stat.sh b/testing/print_stat.sh | ||
12 | index 681a063..0a519f6 100755 | ||
13 | --- a/testing/print_stat.sh | ||
14 | +++ b/testing/print_stat.sh | ||
15 | @@ -1,4 +1,4 @@ | ||
16 | -#!/system/bin/sh | ||
17 | +#!/bin/sh | ||
18 | |||
19 | PHY=`ls /sys/class/ieee80211/` | ||
20 | mkdir -p /debug | ||
21 | -- | ||
22 | 2.7.4 | ||
23 | |||
diff --git a/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts_8.7.1.bb b/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts_8.7.1.bb index 07a164be..49ac4c9c 100644 --- a/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts_8.7.1.bb +++ b/recipes-connectivity/wl18xx-target-scripts/wl18xx-target-scripts_8.7.1.bb | |||
@@ -5,7 +5,11 @@ LIC_FILES_CHKSUM = "file://README;beginline=1;endline=21;md5=b8d6a0865f50159bf5c | |||
5 | # Tag: R8.7_SP1 (8.7.1) | 5 | # Tag: R8.7_SP1 (8.7.1) |
6 | SRCREV = "a07b6e711d2a70608101d3d6cdc5749c4d8a96d5" | 6 | SRCREV = "a07b6e711d2a70608101d3d6cdc5749c4d8a96d5" |
7 | BRANCH = "sitara-scripts" | 7 | BRANCH = "sitara-scripts" |
8 | SRC_URI = "git://git.ti.com/wilink8-wlan/wl18xx-target-scripts.git;protocol=git;branch=${BRANCH}" | 8 | SRC_URI = "git://git.ti.com/wilink8-wlan/wl18xx-target-scripts.git;protocol=git;branch=${BRANCH} \ |
9 | file://0001-print_stat.sh-replace-system-bin-sh-with-bin-sh.patch \ | ||
10 | " | ||
11 | |||
12 | PR = "r1" | ||
9 | 13 | ||
10 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
11 | 15 | ||
@@ -14,7 +18,7 @@ FILES_${PN} += "${datadir}/wl18xx/" | |||
14 | do_install() { | 18 | do_install() { |
15 | install -d ${D}${datadir}/wl18xx/ | 19 | install -d ${D}${datadir}/wl18xx/ |
16 | 20 | ||
17 | scripts=`find ./ -type f -name "*.*"` | 21 | scripts=`find ./* -type f -name "*.*"` |
18 | for s in $scripts | 22 | for s in $scripts |
19 | do | 23 | do |
20 | install -m 0755 $s ${D}${datadir}/wl18xx/ | 24 | install -m 0755 $s ${D}${datadir}/wl18xx/ |