summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorIvan Pang <i-pang@ti.com>2017-08-31 02:44:48 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-01 12:51:03 -0400
commitf536ac3876d6bc82927cb9ebad75dee4e76c409c (patch)
treeb96b08f45afabb65d258a85183b8dc117d4836b7 /recipes-bsp
parentc3c780c881a0290bbd9a4a909357995bfb2b6936 (diff)
downloadmeta-ti-f536ac3876d6bc82927cb9ebad75dee4e76c409c.tar.gz
wdtimer-rtos: added recipe for wdtimer
Signed-off-by: Ivan Pang <i-pang@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/wdtimer/wdtimer-rtos_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/wdtimer/wdtimer-rtos_git.bb b/recipes-bsp/wdtimer/wdtimer-rtos_git.bb
new file mode 100644
index 00000000..5e23dbda
--- /dev/null
+++ b/recipes-bsp/wdtimer/wdtimer-rtos_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Watchdog Timer (wdtimer) test example"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://WatchdogTimer.xdc;beginline=1;endline=31;md5=837fb1761f89c7671e79bd5992bcf9e4"
5
6inherit ti-pdk
7
8COMPATIBLE_MACHINE = "k2hk-evm|k2e-evm|k2l-evm"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11WATCHDOG_TIMER_GIT_URI = "git://git.ti.com/keystone-rtos/wdtimer.git"
12WATCHDOG_TIMER_GIT_PROTOCOL = "git"
13WATCHDOG_TIMER_GIT_BRANCH = "master"
14WATCHDOG_TIMER_GIT_DESTSUFFIX = "git/ti/instrumentation/wdtimer"
15
16# Below commit ID corresponds to "DEV.WDTIMER.01.00.00.03"
17WATCHDOG_TIMER_SRCREV = "db973cf8d71460537e2738af0ff094becc7ac454"
18
19BRANCH = "${WATCHDOG_TIMER_GIT_BRANCH}"
20SRC_URI = "${WATCHDOG_TIMER_GIT_URI};destsuffix=${WATCHDOG_TIMER_GIT_DESTSUFFIX};protocol=${WATCHDOG_TIMER_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${WATCHDOG_TIMER_SRCREV}"
23PV = "01.00.00.03"
24PR = "r0"
25
26S = "${WORKDIR}/git/ti/instrumentation/wdtimer"
27
28# HTML doc link params
29PDK_COMP_LINK_TEXT = "Watchdog Timer"