summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-09 06:50:34 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-05-13 00:54:29 +0000
commiteea4166cbad972d68a4e7d045ffeab55e5539e14 (patch)
tree2d11efc741bd895c6ddfb8aaea4f85472d708afd /recipes-bsp
parenta83fb916dcfcad3028256ba8ff7d0626cf475cc5 (diff)
downloadmeta-ti-eea4166cbad972d68a4e7d045ffeab55e5539e14.tar.gz
ti-img-encode-decode: not compatible with K5.4 - remove
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-img-encode-decode/ti-img-encode-decode_1.0.0.bb31
-rw-r--r--recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb18
-rw-r--r--recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb18
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb34
4 files changed, 0 insertions, 101 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/ti-img-encode-decode_1.0.0.bb b/recipes-bsp/ti-img-encode-decode/ti-img-encode-decode_1.0.0.bb
deleted file mode 100644
index 0192717e..00000000
--- a/recipes-bsp/ti-img-encode-decode/ti-img-encode-decode_1.0.0.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Kernel drivers for the IMG VXE384 MP2 and D5520 encoder/decoder found in TI SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://driver/common/dq.c;beginline=1;endline=16;md5=e015e28ff5e88576dab9fdf641e3dbfe"
4
5inherit module
6
7MACHINE_KERNEL_PR_append = "g"
8PR = "${MACHINE_KERNEL_PR}"
9
10COMPATIBLE_MACHINE = "j7"
11
12SRCREV = "0eba3678300f649e49f03d92d1b624cf0e008008"
13
14EXTRA_OEMAKE = "KPATH=${STAGING_KERNEL_DIR} KCONF=${STAGING_KERNEL_BUILDDIR}"
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17BRANCH = "master"
18SRC_URI = "git://git.ti.com/jacinto7_multimedia/ti-img-encode-decode.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21
22do_compile() {
23 oe_runmake all -C ${S}/linux/decoder
24 oe_runmake all -C ${S}/linux/encoder
25}
26
27do_install() {
28 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
29 install -m 644 ${S}/linux/decoder/vxd-dec.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
30 install -m 644 ${S}/linux/encoder/vxe-enc.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
31}
diff --git a/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb b/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
deleted file mode 100644
index 48a17537..00000000
--- a/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Test applications for TI DEC (v4l2 decoder for IMG D5520)"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://main.c;beginline=1;endline=14;md5=f17e17d664f72942124e4fcf06c178ee"
4
5DEPENDS = "libdrm ffmpeg"
6
7inherit autotools pkgconfig
8
9PR = "r1"
10SRCREV = "94a80c8c090dbfdc7fafd4e5bb78c2091e715af2"
11
12EXTRA_OEMAKE = "CC="${CC}""
13TARGET_CC_ARCH += "${LDFLAGS}"
14
15BRANCH = "master"
16SRC_URI = "git://git.ti.com/jacinto7_multimedia/viddec-test-app.git;protocol=git;branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
diff --git a/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb b/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
deleted file mode 100644
index 3bb5d745..00000000
--- a/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Test applications for TI ENC (v4l2 encoder for IMG VXE384)"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://main.c;beginline=1;endline=14;md5=3545dd5bdf513840937d38c10b866605"
4
5DEPENDS = "libdrm"
6
7inherit autotools pkgconfig
8
9PR = "r0"
10SRCREV = "a5e7d820bea1be24f25a8369d4d4521c784f869a"
11
12EXTRA_OEMAKE = "CC="${CC}""
13TARGET_CC_ARCH += "${LDFLAGS}"
14
15BRANCH = "master"
16SRC_URI = "git://git.ti.com/jacinto7_multimedia/videnc-test-app.git;protocol=git;branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
deleted file mode 100644
index 2812fa2c..00000000
--- a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "Video Decoding Firmware Packaging recipe"
2LICENSE = "TI-TFL"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=84ca7278930db001870686ad997d6bb1"
4
5BRANCH = "master"
6SRCREV = "0acbf1d0a7c7eaca0ef14c1a30ce313ea82147e5"
7
8SRC_URI = "git://git.ti.com/jacinto7_multimedia/ti-img-encode-decode.git;protocol=git;branch=${BRANCH}"
9
10S = "${WORKDIR}/git"
11
12PV = "1.0-git${SRCPV}"
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15VXD_FW_DIR = "${S}/decoder/firmware/"
16
17# make sure that lib/firmware, and all its contents are part of the package
18FILES_${PN} += "${base_libdir}/firmware"
19
20do_install() {
21 install -d ${D}${base_libdir}/firmware
22 install -m 0755 ${VXD_FW_DIR}/pvdec_full_bin.fw ${D}${base_libdir}/firmware
23}
24
25# This is used to prevent the build system to strip the executables
26INHIBIT_PACKAGE_STRIP = "1"
27# This is used to prevent the build system to split the debug info in a separate file
28INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
29# As it likely to be a different arch from the Yocto build, disable checking by adding "arch" to INSANE_SKIP
30INSANE_SKIP_${PN} += "arch"
31
32# we don't want to configure and build the source code
33do_compile[noexec] = "1"
34do_configure[noexec] = "1"