summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-13 06:59:55 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-07-16 12:44:05 +0000
commitcf5061fe72448039974765bb45bf446ae7f2c2c2 (patch)
tree3dc6c5132d4bf08652768a2adf0fa33b6434b4e0 /recipes-bsp
parentbd9b3d04d2a711ccbd4172483c2a4dd5463cb6e1 (diff)
downloadmeta-ti-cf5061fe72448039974765bb45bf446ae7f2c2c2.tar.gz
amx3-cm3,u-boot-ti: Pin to gcc compiler
Using clang as default compiler fails to build these since these packages explicitly asks for gcc as compiler this ensures that we meet that demand Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb1
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc2
2 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
index 79166ca9..bbbc3ec1 100644
--- a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
+++ b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
@@ -26,3 +26,4 @@ do_install() {
26FILES_${PN} += "${base_libdir}/firmware" 26FILES_${PN} += "${base_libdir}/firmware"
27 27
28COMPATIBLE_MACHINE = "(ti-soc)" 28COMPATIBLE_MACHINE = "(ti-soc)"
29TOOLCHAIN = "gcc"
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index b66a7a6f..f1187e64 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -370,3 +370,5 @@ do_deploy_append_keystone () {
370 fi 370 fi
371 fi 371 fi
372} 372}
373
374TOOLCHAIN = "gcc"