diff options
author | Denys Dmytriyenko <denys@ti.com> | 2017-12-14 02:23:11 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-12-14 12:42:49 -0500 |
commit | b9e43d5c236f094ca0c60e31bea7835924df036d (patch) | |
tree | b54e84ba8e8f1474c4ed5024b2a3c8e6f7fa987b /recipes-bsp | |
parent | ac59a53106a8d11b6e729f1cc23300d4616fb3b2 (diff) | |
download | meta-ti-b9e43d5c236f094ca0c60e31bea7835924df036d.tar.gz |
edma3-lld: pass TOOLCHAIN_OPTIONS and fix host-user-contamination
1. Need TOOLCHAIN_OPTIONS to pass --sysroot parameter for internal toolchain
2. Use proper cp parameters to handle files ownership correctly
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/edma3-lld/edma3-lld_git.bb | 26 |
1 files changed, 14 insertions, 12 deletions
diff --git a/recipes-bsp/edma3-lld/edma3-lld_git.bb b/recipes-bsp/edma3-lld/edma3-lld_git.bb index e197d0b1..38db2e21 100644 --- a/recipes-bsp/edma3-lld/edma3-lld_git.bb +++ b/recipes-bsp/edma3-lld/edma3-lld_git.bb | |||
@@ -24,41 +24,43 @@ do_compile () { | |||
24 | cd ${S}/packages | 24 | cd ${S}/packages |
25 | for platform in ${PLATFORMLIST} | 25 | for platform in ${PLATFORMLIST} |
26 | do | 26 | do |
27 | ROOTDIR=${S} CROSSCC="${TARGET_PREFIX}gcc" CROSSAR="${TARGET_PREFIX}ar" \ | 27 | ROOTDIR=${S} CROSSCC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" CROSSAR="${TARGET_PREFIX}ar" \ |
28 | CROSSLNK="${TARGET_PREFIX}gcc" INTERNAL_SW_ROOT="${S}" make \ | 28 | CROSSLNK="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" INTERNAL_SW_ROOT="${S}" make \ |
29 | PLATFORM="$platform" TARGET=a15 TOOLCHAIN_a15=GCC FORMAT=ELF \ | 29 | PLATFORM="$platform" TARGET=a15 TOOLCHAIN_a15=GCC FORMAT=ELF \ |
30 | SONAME=libedma3.so all | 30 | SONAME=libedma3.so all |
31 | done | 31 | done |
32 | } | 32 | } |
33 | 33 | ||
34 | do_install () { | 34 | do_install () { |
35 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
36 | |||
35 | install -d ${D}/${libdir} | 37 | install -d ${D}/${libdir} |
36 | 38 | ||
37 | # Static Libraries | 39 | # Static Libraries |
38 | cp ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/edma3_lld_drv.aa15fg \ | 40 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/edma3_lld_drv.aa15fg \ |
39 | ${D}/${libdir}/libedma3.a | 41 | ${D}/${libdir}/libedma3.a |
40 | cp ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/edma3_lld_rm.aa15fg \ | 42 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/edma3_lld_rm.aa15fg \ |
41 | ${D}/${libdir}/libedma3rm.a | 43 | ${D}/${libdir}/libedma3rm.a |
42 | 44 | ||
43 | # Shared Libraries | 45 | # Shared Libraries |
44 | cp -a ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/libedma* ${D}/${libdir} | 46 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/libedma* ${D}/${libdir} |
45 | cp -a ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/libedma* ${D}/${libdir} | 47 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/libedma* ${D}/${libdir} |
46 | 48 | ||
47 | # Copy Headers | 49 | # Copy Headers |
48 | install -d ${D}/${includedir}/ti/sdo/edma3/drv/ | 50 | install -d ${D}/${includedir}/ti/sdo/edma3/drv/ |
49 | install -d ${D}/${includedir}/ti/sdo/edma3/rm | 51 | install -d ${D}/${includedir}/ti/sdo/edma3/rm |
50 | cp ${S}/packages/ti/sdo/edma3/drv/*.h ${D}/${includedir}/ti/sdo/edma3/drv/ | 52 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/drv/*.h ${D}/${includedir}/ti/sdo/edma3/drv/ |
51 | cp ${S}/packages/ti/sdo/edma3/rm/*.h ${D}/${includedir}/ti/sdo/edma3/rm/ | 53 | cp ${CP_ARGS} ${S}/packages/ti/sdo/edma3/rm/*.h ${D}/${includedir}/ti/sdo/edma3/rm/ |
52 | 54 | ||
53 | # Copy Sample Config | 55 | # Copy Sample Config |
54 | install -d ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms | 56 | install -d ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms |
55 | cp ${S}/examples/edma3_user_space_driver/evmTCI6636K2H/evmTCI6636K2HSample.c \ | 57 | cp ${CP_ARGS} ${S}/examples/edma3_user_space_driver/evmTCI6636K2H/evmTCI6636K2HSample.c \ |
56 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms | 58 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms |
57 | cp ${S}/examples/edma3_user_space_driver/evmTCI6638K2K/evmTCI6638K2KSample.c \ | 59 | cp ${CP_ARGS} ${S}/examples/edma3_user_space_driver/evmTCI6638K2K/evmTCI6638K2KSample.c \ |
58 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms | 60 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms |
59 | cp ${S}/examples/edma3_user_space_driver/evmTCI6630K2L/evmTCI6630K2LSample.c \ | 61 | cp ${CP_ARGS} ${S}/examples/edma3_user_space_driver/evmTCI6630K2L/evmTCI6630K2LSample.c \ |
60 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms | 62 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms |
61 | cp ${S}/examples/edma3_user_space_driver/evmC66AK2E/evmC66AK2ESample.c \ | 63 | cp ${CP_ARGS} ${S}/examples/edma3_user_space_driver/evmC66AK2E/evmC66AK2ESample.c \ |
62 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms | 64 | ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms |
63 | 65 | ||
64 | install -d ${D}/${bindir} | 66 | install -d ${D}/${bindir} |