diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-01-24 20:29:56 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-01-24 20:29:56 +0100 |
commit | 579d8efb3eb25b114de2640d98a511893d2f4841 (patch) | |
tree | 0704588be4d62846cc8a93b9e66f299c28e4e353 /recipes-bsp | |
parent | 7cedbcf68579be63e502d273d16021020a198e47 (diff) | |
download | meta-ti-579d8efb3eb25b114de2640d98a511893d2f4841.tar.gz |
linux-omap4: sync with OE
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
3 files changed, 67 insertions, 1 deletions
diff --git a/recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch b/recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch new file mode 100644 index 00000000..e83a3e25 --- /dev/null +++ b/recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 7699704e011db864c56f333bce9936a36522fb79 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Gardner <tim.gardner@canonical.com> | ||
3 | Date: Thu, 9 Dec 2010 08:16:52 -0700 | ||
4 | Subject: [PATCH 1/2] UBUNTU: [Config] Fix FTBS caused by new binutils | ||
5 | |||
6 | New assemblers need -march=armv7-a+sec on command line or | ||
7 | .arch_extension sec inline to enable use of the smc instruction. | ||
8 | |||
9 | This patch uses as-instr to check the latter to conditionally | ||
10 | enable the former in AFLAGS for files that use smc. | ||
11 | |||
12 | Checked on both old and new binutils to verify that it does | ||
13 | not break old versions. | ||
14 | |||
15 | Signed-off-by: John Rigby <john.rigby@linaro.org> | ||
16 | Signed-off-by: Tim Gardner <tim.gardner@canonical.com> | ||
17 | --- | ||
18 | arch/arm/mach-omap2/Makefile | 4 +++- | ||
19 | 1 files changed, 3 insertions(+), 1 deletions(-) | ||
20 | |||
21 | diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile | ||
22 | index 75251b4..0241b4d 100644 | ||
23 | --- a/arch/arm/mach-omap2/Makefile | ||
24 | +++ b/arch/arm/mach-omap2/Makefile | ||
25 | @@ -29,7 +29,9 @@ obj-$(CONFIG_HOTPLUG_CPU) += omap-hotplug.o | ||
26 | obj-$(CONFIG_ARCH_OMAP4) += omap44xx-smc.o omap4-common.o \ | ||
27 | omap4-wakeupgen.o | ||
28 | |||
29 | -AFLAGS_omap44xx-smc.o :=-Wa,-march=armv7-a | ||
30 | +plus_sec := $(call as-instr,.arch_extension sec,+sec) | ||
31 | +AFLAGS_omap-headsmp.o :=-Wa,-march=armv7-a$(plus_sec) | ||
32 | +AFLAGS_omap44xx-smc.o :=-Wa,-march=armv7-a$(plus_sec) | ||
33 | |||
34 | # Functions loaded to SRAM | ||
35 | obj-$(CONFIG_ARCH_OMAP2420) += sram242x.o | ||
36 | -- | ||
37 | 1.7.0.2 | ||
38 | |||
diff --git a/recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch b/recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch new file mode 100644 index 00000000..ea16ab11 --- /dev/null +++ b/recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From da58d36fb6b13899249bf1efbf25f7385d048bb3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Gardner <tim.gardner@canonical.com> | ||
3 | Date: Tue, 14 Dec 2010 06:56:34 -0700 | ||
4 | Subject: [PATCH 2/2] Add AFLAGS for sleep44xx to fix FTBS | ||
5 | |||
6 | Signed-off-by: Tim Gardner <tim.gardner@canonical.com> | ||
7 | --- | ||
8 | arch/arm/mach-omap2/Makefile | 2 ++ | ||
9 | 1 files changed, 2 insertions(+), 0 deletions(-) | ||
10 | |||
11 | diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile | ||
12 | index 0241b4d..865a3e2 100644 | ||
13 | --- a/arch/arm/mach-omap2/Makefile | ||
14 | +++ b/arch/arm/mach-omap2/Makefile | ||
15 | @@ -59,6 +59,8 @@ obj-$(CONFIG_ARCH_OMAP4) += pm44xx.o pm_bus.o cpuidle44xx.o \ | ||
16 | omap4-mpuss-lowpower.o sleep44xx.o \ | ||
17 | voltage.o opp44xx_data.o | ||
18 | |||
19 | +AFLAGS_sleep44xx.o :=-Wa,-march=armv7-a$(plus_sec) | ||
20 | + | ||
21 | obj-$(CONFIG_PM_DEBUG) += pm-debug.o | ||
22 | obj-$(CONFIG_OMAP_SMARTREFLEX) += sr_device.o smartreflex.o | ||
23 | obj-$(CONFIG_OMAP_SMARTREFLEX_CLASS3) += smartreflex-class3.o | ||
24 | -- | ||
25 | 1.7.0.2 | ||
26 | |||
diff --git a/recipes-bsp/linux/linux-omap4_2.6.35.3.bb b/recipes-bsp/linux/linux-omap4_2.6.35.3.bb index 4db0b284..05025544 100644 --- a/recipes-bsp/linux/linux-omap4_2.6.35.3.bb +++ b/recipes-bsp/linux/linux-omap4_2.6.35.3.bb | |||
@@ -4,7 +4,7 @@ require multi-kernel.inc | |||
4 | 4 | ||
5 | CORTEXA8FIXUP = "no" | 5 | CORTEXA8FIXUP = "no" |
6 | 6 | ||
7 | SRCREV = "35528f5b0481485654a6577306f7a80d9e6a5cf5" | 7 | SRCREV = "ti-ubuntu-2.6.35-980.1release13" |
8 | 8 | ||
9 | SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol=git;branch=ti-ubuntu-L24.11 \ | 9 | SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol=git;branch=ti-ubuntu-L24.11 \ |
10 | file://0001-tiler-avoid-lock-ups-due-to-unmapped-DMM-entries.patch \ | 10 | file://0001-tiler-avoid-lock-ups-due-to-unmapped-DMM-entries.patch \ |
@@ -15,6 +15,8 @@ SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol | |||
15 | file://0006-ARM-Add-option-to-allow-userspace-access-to-performa.patch \ | 15 | file://0006-ARM-Add-option-to-allow-userspace-access-to-performa.patch \ |
16 | file://0007-OMAP4-do-not-force-select-options-which-are-not-requ.patch \ | 16 | file://0007-OMAP4-do-not-force-select-options-which-are-not-requ.patch \ |
17 | file://0008-omap4-pandaboard-add-support-for-DVI-output.patch \ | 17 | file://0008-omap4-pandaboard-add-support-for-DVI-output.patch \ |
18 | file://0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch \ | ||
19 | file://0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch \ | ||
18 | file://defconfig" | 20 | file://defconfig" |
19 | 21 | ||
20 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |