summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorSai Sree Kartheek Adivi <s-adivi@ti.com>2023-02-14 17:18:24 +0530
committerRyan Eatmon <reatmon@ti.com>2023-02-14 07:45:02 -0600
commit2bf12f5449405c6e1600775dee7e3a08f3ab623b (patch)
treece24c9e6efd851544aa8df996110c3b23a71f042 /recipes-bsp
parent937b57b6d63a4267b96f25ec15c2809f7f288f76 (diff)
downloadmeta-ti-2bf12f5449405c6e1600775dee7e3a08f3ab623b.tar.gz
am62axx-evm: Add AM62A HS-FS evm configuration
Lets add the basic AM62A configuration - Add machine conf for AM62A. - The wic images will boot on AM62A HS-FS devices by default. The sysfw image for GP and HS-SE will be packaged in the wic image as tiboot3-am62ax-gp-evm.bin and tiboot3-am62ax-hs-evm.bin respectively. - Add ti-sci-firmware overrides. - Sign ATF, OPTEE and RTOS Firmware. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb4
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend4
2 files changed, 7 insertions, 1 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index e3ffef37..96929286 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -44,7 +44,9 @@ SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs"
44SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 44SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs" 46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
47SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" 47SYSFW_PREFIX_am62axx-evm-k3r5-gp = "fs"
48SYSFW_PREFIX_am62axx-evm-k3r5-hs-fs = "fs"
49SYSFW_PREFIX_am62axx-evm-k3r5-hs-se = "fs"
48 50
49SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 51SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
50 52
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 41071676..70406724 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -39,6 +39,10 @@ do_compile_append_am62xx-lp-evm() {
39 tfa_sign_k3hs 39 tfa_sign_k3hs
40} 40}
41 41
42do_compile_append_am62axx-evm() {
43 tfa_sign_k3hs
44}
45
42do_compile_append_j7-hs-evm() { 46do_compile_append_j7-hs-evm() {
43 tfa_sign_k3hs 47 tfa_sign_k3hs
44} 48}