summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-02 20:19:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-03 09:01:08 +0100
commite6be6e52577c50cc13e9434b297b077820474cf4 (patch)
tree6512c0856955243a31b8377674f68de78d7e8ab8 /recipes-bsp/u-boot
parent13a25a08f2d3b6b00d0cf33855978b215390e710 (diff)
downloadmeta-ti-e6be6e52577c50cc13e9434b297b077820474cf4.tar.gz
TI BSP: add hawkboard support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/dont-inline-weak-symbols.patch45
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb7
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/dont-inline-weak-symbols.patch b/recipes-bsp/u-boot/u-boot/dont-inline-weak-symbols.patch
new file mode 100644
index 00000000..5931ccf0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/dont-inline-weak-symbols.patch
@@ -0,0 +1,45 @@
1Patch initially created by Ron Lee and archived in OE patchwork at
2http://patchwork.openembedded.org/patch/1534/.
3
4GCC 4.4 complains about this now.
5
6Signed-off-by: Ron Lee <ron@debian.org>
7---
8 lib_arm/board.c | 18 +++++++++---------
9 1 files changed, 9 insertions(+), 9 deletions(-)
10
11--- a/lib_arm/board.c
12+++ b/lib_arm/board.c
13@@ -124,23 +124,23 @@
14 * May be supplied by boards if desired
15 */
16 void inline __coloured_LED_init (void) {}
17-void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
18+void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
19 void inline __red_LED_on (void) {}
20-void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
21+void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
22 void inline __red_LED_off(void) {}
23-void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
24+void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
25 void inline __green_LED_on(void) {}
26-void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
27+void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
28 void inline __green_LED_off(void) {}
29-void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
30+void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
31 void inline __yellow_LED_on(void) {}
32-void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
33+void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
34 void inline __yellow_LED_off(void) {}
35-void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
36+void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
37 void inline __blue_LED_on(void) {}
38-void inline blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
39+void blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
40 void inline __blue_LED_off(void) {}
41-void inline blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
42+void blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
43
44 /************************************************************************
45 * Init Utilities *
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 3aa69b77..5546447d 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -66,4 +66,11 @@ SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protoc
66SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620" 66SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
67PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}" 67PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}"
68 68
69# hawkboard - master branch (hawk still .07beta)
70SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
71SRC_URI_hawkboard += "file://dont-inline-weak-symbols.patch"
72SRCREV_hawkboard = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
73PV_hawkboard = "2009.08+gitr${SRCREV}"
74
75
69S = "${WORKDIR}/git" 76S = "${WORKDIR}/git"