summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-08 23:49:01 -0800
committerDenys Dmytriyenko <denys@ti.com>2012-03-15 00:49:33 -0400
commit0d0e2c1e274e1885d8b5cb07421449e9d0016c2c (patch)
treed10c42bdff939a3fd7fb3d5d4d4e512a418b17c1 /recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
parentcf056a6ae089c8078609ee6b644f39b19965fbcb (diff)
downloadmeta-ti-0d0e2c1e274e1885d8b5cb07421449e9d0016c2c.tar.gz
u-boot: Fix config-Always-use-GNU-ld patch to work with dash
>& /dev/null is not ok for dash so use > /dev/null 2>&1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
index 15f22b34..64685e39 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
@@ -1,7 +1,7 @@
1From 06fe8be6b5c70853c0e3fac93d7bba9cb3d0292f Mon Sep 17 00:00:00 2001 1From a8dc33253472328f2af04973575f26e9106db1c3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Dec 2011 08:53:02 -0800 3Date: Wed, 21 Dec 2011 08:53:02 -0800
4Subject: [PATCH 07/10] config: Always use GNU ld 4Subject: [PATCH] config: Always use GNU ld
5 5
6This patch makes sure that we always use the GNU ld. u-boot uses certain 6This patch makes sure that we always use the GNU ld. u-boot uses certain
7construct e.g. OVERLAY which are not implemented in gold therefore it 7construct e.g. OVERLAY which are not implemented in gold therefore it
@@ -20,14 +20,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 1 files changed, 3 insertions(+), 1 deletions(-) 20 1 files changed, 3 insertions(+), 1 deletions(-)
21 21
22diff --git a/config.mk b/config.mk 22diff --git a/config.mk b/config.mk
23index ddaa477..59b3e71 100644 23index ddaa477..139dfa0 100644
24--- a/config.mk 24--- a/config.mk
25+++ b/config.mk 25+++ b/config.mk
26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ 26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\
27 $(if $(call cc-option-sys,$1),$1,$2))) 27 $(if $(call cc-option-sys,$1),$1,$2)))
28 endif 28 endif
29 29
30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \ 30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v > /dev/null 2>&1; \
31+ then echo "$(1)"; else echo "$(2)"; fi; ) 31+ then echo "$(1)"; else echo "$(2)"; fi; )
32 # 32 #
33 # Include the make variables (CC, etc...) 33 # Include the make variables (CC, etc...)
@@ -39,5 +39,5 @@ index ddaa477..59b3e71 100644
39 CPP = $(CC) -E 39 CPP = $(CC) -E
40 AR = $(CROSS_COMPILE)ar 40 AR = $(CROSS_COMPILE)ar
41-- 41--
421.7.2.5 421.7.9.1
43 43