summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-03-18 18:06:38 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-03-25 20:41:12 -0400
commit7a62fcc7db67c58472a069a14c721da842f4099e (patch)
tree987910b4838f572ea73bc1ee3bb01fc1ff76038a /recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb
parent11573bda76f132d356fbc1fb37b6471d13a6bcf4 (diff)
downloadmeta-ti-7a62fcc7db67c58472a069a14c721da842f4099e.tar.gz
u-boot-am37x: modify am37x specific version to use new namespace feature
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb b/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb
new file mode 100644
index 00000000..c25cf1e4
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb
@@ -0,0 +1,38 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for ARM MPU devices"
4
5COMPATIBLE_MACHINE = "am37x-evm|beagleboard"
6
7BRANCH ?= "master"
8
9# v2012.04.01
10SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
11
12SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
13
14# Add patches for the AMSDK
15# - 0001-omap3-beagle-add-usbethaddr....Not for Upstream
16# - 0001-OMAP3-Beagle-Set-BOOTDELAY....Pending Upstream
17# - 0002-am335x-am3517evm-beagleboard....Pending Upstream
18# - 0003-beagleboard-Load-uImage-from....Not for Upstream
19# - 0004-beagleboard-Load-uImage-to....Pending Upstream
20# - 0001-omap3_evm-Added-function....Pending Upstream
21# - 0002-omap3evm-Make-the-board....Pending Upstream
22# - 0003-beagleboard-Make-xM-rev....Pending Upstream
23# - 0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch....Upstreamed
24
25# Add a patch to set a default usbethaddr address to enable the out of box
26# experience.
27SRC_URI += "file://0001-omap3_beagle-add-usbethaddr-setting-to-enable-networ.patch \
28 file://0001-OMAP3-Beagle-Set-BOOTDELAY-to-3.patch \
29 file://0002-am335x-am3517evm-beagleboard-am37x-Add-CONFIG_CMD_AS.patch \
30 file://0003-beagleboard-Load-uImage-from-VFAT-by-default.patch \
31 file://0004-beagleboard-Load-uImage-to-the-default-kernel-linux-.patch \
32 file://0001-omap3_evm-Added-function-calls-to-set-volts-speed-on.patch \
33 file://0002-omap3evm-Make-the-board-start-at-800MHz.patch \
34 file://0003-beagleboard-Make-xM-rev-C-go-to-800MHz.patch \
35 file://0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch \
36 "
37
38SPL_BINARY = "MLO"