summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/traceframework
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-17 00:20:20 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-21 15:15:17 -0500
commit47b1d13a6e7875ce7df3dae94b89b240d3762774 (patch)
tree1e847b8035db693d56a4e18cdc9596506f739698 /recipes-bsp/traceframework
parenta9fe62d130146ed94dc248f35c563c1e76206517 (diff)
downloadmeta-ti-47b1d13a6e7875ce7df3dae94b89b240d3762774.tar.gz
traceframework: Add recipe for TI trace framework library
- Provide libraries and test code for trace framework. - Support framework to stream data from producer to multiple consumers - Supports devices K2H, K2K, K2E, K2L & c6614 Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/traceframework')
-rw-r--r--recipes-bsp/traceframework/traceframework_git.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/traceframework/traceframework_git.bb b/recipes-bsp/traceframework/traceframework_git.bb
new file mode 100644
index 00000000..3211dea2
--- /dev/null
+++ b/recipes-bsp/traceframework/traceframework_git.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "TI Trace Framework library"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/instrumentation/traceframework/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
4
5BRANCH="master"
6SRC_URI = "git://git.ti.com/keystone-rtos/traceframework.git;destsuffix=git/ti/instrumentation/traceframework;protocol=git;branch=${BRANCH}"
7
8# Below commit ID corresponds to DEV.TFWK-01.01.01.06A
9SRCREV = "bd87f53f4d12dc802bcc5609afb7994643e40cb9"
10PV = "01.01.01.06"
11
12COMPATIBLE_MACHINE = "(tci6614-evm|keystone)"
13DEPENDS = "cuia"
14
15DEVICELIST = ""
16DEVICELIST_append_tci6614-evm = "c6614"
17DEVICELIST_append_keystone = "k2k k2h k2e k2l"
18
19PACKAGES =+ "${PN}-test"
20
21FILES_${PN}-test = "${bindir}/tfw*.out \
22 ${bindir}/*.txt"
23
24BASEDIR = "${WORKDIR}/git"
25S = "${BASEDIR}/ti/instrumentation/traceframework"
26
27EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} \
28 CUIA_INSTALL_DIR=${STAGING_INCDIR} CUIA_LIB_DIR=${STAGING_LIBDIR}"
29
30do_compile () {
31# making the library
32 oe_runmake clean
33 oe_runmake lib
34
35# make the test application
36 for device in ${DEVICELIST}
37 do
38 oe_runmake tests DEVICE="$device" TFW_INC_DIR=${BASEDIR} TFW_SRC_DIR=${S} \
39 TARGET_ROOT_DIR=${D}
40 done
41}
42
43do_install() {
44 for device in ${DEVICELIST}
45 do
46 oe_runmake install DEVICE="$device" TFW_SRC_DIR=${S} TARGET_ROOT_DIR=${D}
47 done
48}