summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/starterware/starterware_git.bb
diff options
context:
space:
mode:
authorHongmei Gou <a0271529@ti.com>2017-09-01 21:46:43 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-05 11:29:58 -0400
commit350ccbc9a81b5765cba1ce45ba87f00b157700f9 (patch)
treee5038bde1e7a26d686954c9849aa891f8a3c1bbe /recipes-bsp/starterware/starterware_git.bb
parent1c924c003fb0cba826ef373bbafe4c81869a9120 (diff)
downloadmeta-ti-350ccbc9a81b5765cba1ce45ba87f00b157700f9.tar.gz
starterware: add starterware for linux which installs header files only
* starterware.inc is created to host the common information Signed-off-by: Hongmei Gou <a0271529@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/starterware/starterware_git.bb')
-rw-r--r--recipes-bsp/starterware/starterware_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-bsp/starterware/starterware_git.bb b/recipes-bsp/starterware/starterware_git.bb
new file mode 100644
index 00000000..3adfac36
--- /dev/null
+++ b/recipes-bsp/starterware/starterware_git.bb
@@ -0,0 +1,16 @@
1require starterware.inc
2
3PR = "${INC_PR}.0"
4
5ALLOW_EMPTY_${PN} = "1"
6
7CLEANBROKEN = "1"
8
9do_compile() {
10 :
11}
12
13do_install () {
14 install -d ${D}${includedir}/ti/starterware
15 find . -name "*.h" -type f | xargs -I {} cp --parents --no-preserve=ownership {} ${D}${includedir}/ti/starterware
16}