summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-09-19 02:22:39 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-28 13:24:43 -0400
commit511b167f6683b76ea8f3853e3b8ea0199b0fa25d (patch)
treef4db35a211e9bfb76ca0dc9591ecc6aa27c214f5 /recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
parent7d038d894ad6584d81063fef6b246289d3565a98 (diff)
downloadmeta-ti-511b167f6683b76ea8f3853e3b8ea0199b0fa25d.tar.gz
pruss-lld: Add rtos recipe & update the version to 1.0.0.7
RTOS low level driver for the PRUSS module Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb')
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
new file mode 100644
index 00000000..50682867
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "TI RTOS low level driver library for PRUSS"
2
3inherit ti-pdk
4require recipes-bsp/pruss-lld/pruss-lld.inc
5
6PR = "${INC_PR}.0"
7
8S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
9
10DEPENDS_append = " osal-rtos"
11DEPENDS_append_ti33x = " starterware-rtos"
12DEPENDS_append_ti43x = " starterware-rtos"
13
14# Build with make instead of XDC
15TI_PDK_XDCMAKE = "0"
16
17export PDK_PRUSS_ROOT_PATH ="${WORKDIR}/build"
18export DEST_ROOT="${WORKDIR}/build"
19
20# HTML doc link params
21PDK_COMP_LINK_TEXT = "PRUSS LLD"
22
23INSANE_SKIP_${PN} = "arch"