summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pru
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-09-11 22:18:27 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-09-12 11:24:53 -0400
commited4ebd0b7c7a4fe24601144f03c4ecb438128698 (patch)
treec7a057faf86f1f338b0244a213f786dd7993f25b /recipes-bsp/pru
parentf3c7afb5a3f762894fb0476081d862cb3d54e2dd (diff)
downloadmeta-ti-ed4ebd0b7c7a4fe24601144f03c4ecb438128698.tar.gz
ti-pru-sw-edma-driver: let module.bbclass package modules automatically
The new method is to automatically package modules into kernel-module-<modname> and make the custom name depend on the standard unified one. Messing with FILES_${PN} usually causes problems, so avoid it and let module.bbclass do it's magic. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pru')
-rw-r--r--recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
index c7fdfd1e..1a418d7c 100644
--- a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
+++ b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
@@ -7,7 +7,7 @@ COMPATIBLE_MACHINE = "omapl138"
7 7
8INHIBIT_PACKAGE_STRIP = "1" 8INHIBIT_PACKAGE_STRIP = "1"
9 9
10MACHINE_KERNEL_PR_append = "a+svnr${SRCPV}" 10MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}"
11PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"
12 12
13SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''" 13SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''"
@@ -28,5 +28,3 @@ do_install () {
28 install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru 28 install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru
29 install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/ 29 install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/
30} 30}
31
32FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/edmautils.ko"