summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-03-30 17:41:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-04-06 18:46:00 -0400
commitf59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca (patch)
tree247fd11e0b217963fd0a6e6aa061bc0f35248532 /recipes-bsp/powervr-drivers
parentc6d2bd9547ad46577c0d4ca9df7e1f8ab75f2a78 (diff)
downloadmeta-ti-f59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca.tar.gz
omap3-sgx-modules: Install via the kernel's "modules_install" target.
* This allows the modules to have a consistent installation structure when directly building from source. * Previously, these modules would be manualy installed to appears as in-tree modules. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb13
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb13
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb14
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb14
4 files changed, 8 insertions, 46 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
index bd476f01..a54a643b 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb
@@ -10,7 +10,7 @@ BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "b" 13MACHINE_KERNEL_PR_append = "c"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16DEFAULT_PREFERENCE_omap3 = "99" 16DEFAULT_PREFERENCE_omap3 = "99"
@@ -32,17 +32,8 @@ TI_PLATFORM_ti814x = "ti81xx"
32TI_PLATFORM_ti816x = "ti81xx" 32TI_PLATFORM_ti816x = "ti81xx"
33TI_PLATFORM_ti33x = "ti335x" 33TI_PLATFORM_ti33x = "ti335x"
34 34
35MODULESLOCATION_omap3 = "dc_omapfb3_linux"
36MODULESLOCATION_ti814x = "dc_ti81xx_linux"
37MODULESLOCATION_ti816x = "dc_ti81xx_linux"
38MODULESLOCATION_ti33x = "dc_ti335x_linux"
39
40MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}" 35MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
41 36
42do_install() { 37do_install() {
43 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 38 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
44 cp ${S}/pvrsrvkm.ko \
45 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
46 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
47 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
48} 39}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
index 4b97bbc4..cd6dbe42 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
@@ -10,7 +10,7 @@ IMGPV = "1.9.2188537"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "c" 13MACHINE_KERNEL_PR_append = "d"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16DEFAULT_PREFERENCE = "-1" 16DEFAULT_PREFERENCE = "-1"
@@ -44,19 +44,10 @@ TI_PLATFORM_ti814x = "ti81xx"
44TI_PLATFORM_ti816x = "ti81xx" 44TI_PLATFORM_ti816x = "ti81xx"
45TI_PLATFORM_ti33x = "ti335x" 45TI_PLATFORM_ti33x = "ti335x"
46 46
47MODULESLOCATION_omap3 = "dc_omapfb3_linux"
48MODULESLOCATION_ti814x = "dc_ti81xx_linux"
49MODULESLOCATION_ti816x = "dc_ti81xx_linux"
50MODULESLOCATION_ti33x = "dc_ti335x_linux"
51
52MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0" 47MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0"
53 48
54MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1" 49MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1"
55 50
56do_install() { 51do_install() {
57 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 52 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
58 cp ${S}/pvrsrvkm.ko \
59 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
60 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
61 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
62} 53}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
index a1d95bfc..1ac60da7 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "c" 13MACHINE_KERNEL_PR_append = "d"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" 16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
@@ -55,18 +55,8 @@ TI_PLATFORM_ti816x = "ti81xx"
55TI_PLATFORM_ti33x = "ti335x" 55TI_PLATFORM_ti33x = "ti335x"
56TI_PLATFORM_ti43x = "ti43xx" 56TI_PLATFORM_ti43x = "ti43xx"
57 57
58MODULESLOCATION_omap3 = "dc_omapfb3_linux"
59MODULESLOCATION_ti814x = "dc_ti81xx_linux"
60MODULESLOCATION_ti816x = "dc_ti81xx_linux"
61MODULESLOCATION_ti33x = "dc_ti335x_linux"
62MODULESLOCATION_ti43x = "dc_ti43xx_linux"
63
64MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" 58MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
65 59
66do_install() { 60do_install() {
67 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 61 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
68 cp ${S}/pvrsrvkm.ko \
69 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
70 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
71 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
72} 62}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
index 6a07d4f8..cf042fcd 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "a" 13MACHINE_KERNEL_PR_append = "b"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" 16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
@@ -51,18 +51,8 @@ TI_PLATFORM_ti816x = "ti81xx"
51TI_PLATFORM_ti33x = "ti335x" 51TI_PLATFORM_ti33x = "ti335x"
52TI_PLATFORM_ti43x = "ti43xx" 52TI_PLATFORM_ti43x = "ti43xx"
53 53
54MODULESLOCATION_omap3 = "dc_omapfb3_linux"
55MODULESLOCATION_ti814x = "dc_ti81xx_linux"
56MODULESLOCATION_ti816x = "dc_ti81xx_linux"
57MODULESLOCATION_ti33x = "dc_ti335x_linux"
58MODULESLOCATION_ti43x = "dc_ti43xx_linux"
59
60MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" 54MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
61 55
62do_install() { 56do_install() {
63 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 57 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
64 cp ${S}/pvrsrvkm.ko \
65 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
66 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
67 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
68} 58}