summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/ti-sgx-ddk-km
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-09-12 01:23:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-12 22:20:48 +0000
commit8bd0b61b89819f2143db33dda39b9b1cd6c03ae6 (patch)
tree76d6e200bc6136e3fad75fa59246e0ec85d8efcc /recipes-bsp/powervr-drivers/ti-sgx-ddk-km
parent7f2ab381b8956c705eb01680aea81d30dee31f59 (diff)
downloadmeta-ti-8bd0b61b89819f2143db33dda39b9b1cd6c03ae6.tar.gz
ti-sgx-ddk-km: also support arm-oe-linux-gnueabi as a hardfp compiler
OE-built internal toolchain doesn't use "-gnueabihf" suffix and instead uses "-gnueabi" for both softfp and hardfp. For now we only support hardfp (user-space binaries are only available in hardfp), but would be nice to check for "callconvention-hard" before applying the patch. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers/ti-sgx-ddk-km')
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch
new file mode 100644
index 00000000..071ce0ca
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-km-support-OpenEmbedded-hardfp-toolchain-w-o-gnueabi.patch
@@ -0,0 +1,34 @@
1From 755632b4f3a40996a12bc7816a9839af7112040a Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Mon, 9 Sep 2019 17:05:48 -0400
4Subject: [PATCH] km: support OpenEmbedded hardfp toolchain w/o -gnueabihf
5 suffix
6
7Signed-off-by: Denys Dmytriyenko <denys@ti.com>
8---
9 eurasia_km/eurasiacon/build/linux2/config/compiler.mk | 6 +++---
10 1 file changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
13index dead2f9..2ba3e5e 100644
14--- a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
15+++ b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
16@@ -68,12 +68,12 @@ define calculate-compiler-preferred-target
17 ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
18 $(1)_compiler_preferred_target := aarch64-linux-gnu
19 endif
20+ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
21+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
22+ endif
23 ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
24 $(1)_compiler_preferred_target := arm-linux-gnueabi
25 endif
26- ifneq ($$(filter arm-%-gnueabihf,$$($(1)_compiler_preferred_target)),)
27- $(1)_compiler_preferred_target := arm-linux-gnueabihf
28- endif
29 endif
30 endef
31
32--
332.7.4
34