summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/ti-img-rogue-driver
diff options
context:
space:
mode:
authorGowtham Tammana <g-tammana@ti.com>2020-10-28 23:36:08 +0000
committerDan Murphy <dmurphy@ti.com>2020-11-02 16:13:13 -0600
commitd25b8ebe55d57d4770b19ac8f077fedabdb4f937 (patch)
tree58e137447e767784e839b6043b6ee0c5749f49c7 /recipes-bsp/powervr-drivers/ti-img-rogue-driver
parentdfe86b766030553e40fe4ba2c769cf63edc90df1 (diff)
downloadmeta-ti-d25b8ebe55d57d4770b19ac8f077fedabdb4f937.tar.gz
ti-img-rogue-driver: pull general toolchain support
The patch for supporting the general toolchain is pulled into the repo. Removing it here from the recipe. Signed-off-by: Gowtham Tammana <g-tammana@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers/ti-img-rogue-driver')
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch b/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
deleted file mode 100644
index 4dc219cd..00000000
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1From dbdbd9309a58ee723fc827ef5fd45c28347cf61f Mon Sep 17 00:00:00 2001
2From: Eric Ruei <e-ruei1@ti.com>
3Date: Tue, 7 May 2019 17:06:09 -0400
4Subject: [PATCH] km: support general toolchain
5
6This is a patch from IMG to support general toolchains such as
7aarch64-oe-linux-gnu, aarch64-poky-linux-gnu, arm-none-linux-gnueabi
8per IMG ticket 122059
9
10Signed-off-by: Eric Ruei <e-ruei1@ti.com>
11Signed-off-by: Denys Dmytriyenko <denys@ti.com>
12---
13 build/linux/config/compiler.mk | 12 +++++++++++-
14 .../build/linux/config/compilers/arm-linux-gnueabi.mk | 6 ++++++
15 2 files changed, 17 insertions(+), 1 deletion(-)
16 create mode 100644 build/linux/config/compilers/arm-linux-gnueabi.mk
17
18diff --git a/build/linux/config/compiler.mk b/build/linux/config/compiler.mk
19index 82c9d44..dead2f9 100644
20--- a/build/linux/config/compiler.mk
21+++ b/build/linux/config/compiler.mk
22@@ -48,13 +48,14 @@ define calculate-compiler-preferred-target
23 ifeq ($(2),qcc)
24 $(1)_compiler_preferred_target := qcc
25 else
26- $(1)_compiler_preferred_target := $$(subst --,-,$$(shell $(2) -dumpmachine))
27+ $(1)_compiler_preferred_target := $$(subst --,-,$$(subst unknown,,$$(shell $(2) -dumpmachine)))
28 ifeq ($$($(1)_compiler_preferred_target),)
29 $$(warning No output from '$(2) -dumpmachine')
30 $$(warning Check that the compiler is in your PATH and CROSS_COMPILE is)
31 $$(warning set correctly.)
32 $$(error Unable to run compiler '$(2)')
33 endif
34+ $$(warning $(1) $(2))
35 ifneq ($$(filter %-w64-mingw32,$$($(1)_compiler_preferred_target)),)
36 # Use the compiler target name.
37 else
38@@ -64,6 +65,15 @@ define calculate-compiler-preferred-target
39 ifneq ($$(filter arm-linux-android,$$($(1)_compiler_preferred_target)),)
40 $(1)_compiler_preferred_target := arm-linux-androideabi
41 endif
42+ ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
43+ $(1)_compiler_preferred_target := aarch64-linux-gnu
44+ endif
45+ ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
46+ $(1)_compiler_preferred_target := arm-linux-gnueabi
47+ endif
48+ ifneq ($$(filter arm-%-gnueabihf,$$($(1)_compiler_preferred_target)),)
49+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
50+ endif
51 ifneq ($$(filter clang%,$(2)),)
52 ifeq ($(1),target)
53 ifeq (arm-linux-gnueabihf,$$(CROSS_TRIPLE))
54--
552.7.4
56