summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pm-lld
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-09-18 23:54:28 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-28 13:24:39 -0400
commit7d038d894ad6584d81063fef6b246289d3565a98 (patch)
tree739ff54fc58e863f1ee9fc3bb243056b92c31f1b /recipes-bsp/pm-lld
parentf6726f6ffa1cda6e1a7807cdda2946677d0208d4 (diff)
downloadmeta-ti-7d038d894ad6584d81063fef6b246289d3565a98.tar.gz
pm-lld-rtos: Adding rtos recipe for pm-lld
TI RTOS low level driver for Power Management module (PM) Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pm-lld')
-rw-r--r--recipes-bsp/pm-lld/pm-lld-rtos_git.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-bsp/pm-lld/pm-lld-rtos_git.bb b/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
new file mode 100644
index 00000000..6fedc80f
--- /dev/null
+++ b/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
@@ -0,0 +1,56 @@
1SUMMARY = "TI RTOS driver for Power Management module (PM)"
2
3require recipes-ti/includes/ti-paths.inc
4inherit ti-pdk
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://Power.h;beginline=1;endline=31;md5=527b91fdcd26cd19ac07a754f45dedbe"
8
9COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12
13PM_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pm-lld.git"
14PM_LLD_GIT_PROTOCOL = "git"
15PM_LLD_GIT_BRANCH = "int_pm_am335x"
16PM_LLD_GIT_BRANCH_dra7xx-evm = "master"
17PM_LLD_GIT_DESTSUFFIX = "git/ti/drv/pm"
18
19# Below commit ID corresponds to "DEV.PM_LLD.01.04.00.01"
20PM_LLD_SRCREV = "c4908f94b3e655e6298aa9bfe9bbffbbc5d16111"
21
22# Below commit ID corresponds to "REL.PDK.TDA.01.07.00.06"
23PM_LLD_SRCREV_dra7xx-evm = "46ea13503d2991f636197edb206a9f62cea398d4"
24
25BRANCH = "${PM_LLD_GIT_BRANCH}"
26SRC_URI = "${PM_LLD_GIT_URI};destsuffix=${PM_LLD_GIT_DESTSUFFIX};protocol=${PM_LLD_GIT_PROTOCOL};branch=${BRANCH}"
27
28SRCREV = "${PM_LLD_SRCREV}"
29PV = "01.04.00.01"
30PR = "r0"
31
32S = "${WORKDIR}/${PM_LLD_GIT_DESTSUFFIX}"
33
34DEPENDS_append = " ti-sysbios \
35 osal-rtos \
36"
37DEPENDS_append_ti33x = " starterware-rtos \
38"
39DEPENDS_append_ti43x = " starterware-rtos \
40"
41export PDK_PM_ROOT_PATH = "${WORKDIR}/build"
42export DEST_ROOT="${S}"
43
44# Build with make instead of XDC
45TI_PDK_XDCMAKE = "0"
46
47do_compile_append() {
48 # Delete archive created by XDC release command since it does not contain all content
49 find -name "*.tar" -exec rm -f {} \;
50
51 # Archive from build/ to capture ti/drv/pm/ in archive
52 cd ${B}
53 tar -cf pm_lld.tar --exclude='*.tar' ./*
54}
55
56INSANE_SKIP_${PN} = "arch staticdev"