summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pa-lld/pa-lld_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-12-19 05:38:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-18 18:33:34 -0500
commit838c9edd2e6afe778ce49e32dd9c23c5985eefb8 (patch)
treec716ea8d89e04474c565ba3da988ac80408e6166 /recipes-bsp/pa-lld/pa-lld_git.bb
parentbd65d9994ea25c6c222d61f0846b0fce7f7fa777 (diff)
downloadmeta-ti-838c9edd2e6afe778ce49e32dd9c23c5985eefb8.tar.gz
pa-lld: Add recipes for PA low level driver and test code
- Provides low level driver for Packet accelerator module - Supports k2h, k2k, k2l & k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pa-lld/pa-lld_git.bb')
-rw-r--r--recipes-bsp/pa-lld/pa-lld_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb
new file mode 100644
index 00000000..63e34add
--- /dev/null
+++ b/recipes-bsp/pa-lld/pa-lld_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "TI PA LLD library"
2
3DEPENDS = "common-csl-ip rm-lld"
4
5include pa-lld.inc
6
7do_compile () {
8# Now build the lld in the updated directory
9 make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
10 make -f makefile_armv7 DEVICE=k2l lib PDK_INSTALL_PATH=${STAGING_INCDIR}
11}
12
13do_install () {
14 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
15}