summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal/osal-test_git.bb
diff options
context:
space:
mode:
authorJustin Sobota <jsobota@ti.com>2016-12-15 21:54:39 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-19 18:15:09 -0500
commitacb8746388a6c4f9ba212f5f4848878d35c2770b (patch)
tree2b56b4063984c0cf26d168fb19b95564a9b29dc0 /recipes-bsp/osal/osal-test_git.bb
parentc971a8f601d6c7afca40844c49c3a9914b15f762 (diff)
downloadmeta-ti-acb8746388a6c4f9ba212f5f4848878d35c2770b.tar.gz
osal: Upstream version 1.0.0.5E
Signed-off-by: Justin Sobota <jsobota@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/osal/osal-test_git.bb')
-rw-r--r--recipes-bsp/osal/osal-test_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb
new file mode 100644
index 00000000..9d4fa6d3
--- /dev/null
+++ b/recipes-bsp/osal/osal-test_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "TI OSAL tests"
2
3DEPENDS="common-csl-ip osal"
4
5include osal.inc
6
7PR = "${INC_PR}.0"
8
9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
10
11do_compile () {
12# Build the tests
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR}
14 make -f makefile_armv7 tests PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}
15}
16
17do_install () {
18# Install the binary
19 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_BIN_BASE_DIR=${D}${bindir} OSAL_SRC_DIR=${S}
20}