summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb
diff options
context:
space:
mode:
authorParesh Bhagat <p-bhagat@ti.com>2024-02-21 16:52:18 +0530
committerRyan Eatmon <reatmon@ti.com>2024-02-21 14:27:33 -0600
commit474480951631a16c28ccfe675cb88a657f34d625 (patch)
tree9229e0d58bcde24c430f4ebe11ccdc86b375ff70 /meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb
parent713ef2619a7a0db73ceccda655d3df087e0c0d15 (diff)
downloadmeta-ti-474480951631a16c28ccfe675cb88a657f34d625.tar.gz
Rework jailhouse recipe to support different image build
This patch moves the jailhouse recipe general variables to a ti-jailhouse.inc file along with fetch and compile task. Jailhouse repo also contains some demo applications which can be packaged alone in filesytem and does not require packaging jailhouse module, firmware and tool. So add a new recipe jailhouse-inmate which can be used to only package those demos. The existing jailhouse recipe will contain variables and other dependencies needed for do_install task for jailhouse module, tools, demos etc. The do_install of jailhouse inmate recipe will only package demo applications. This new recipe(jailhouse-inmate) will be added to a new image in meta-arago. The new image will be used for jailhouse second linux instance or cell. Signed-off-by: Paresh Bhagat <p-bhagat@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb')
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb
new file mode 100644
index 00000000..39654a53
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse-inmate.bb
@@ -0,0 +1,12 @@
1require ti-jailhouse.inc
2
3do_install() {
4
5 install -d ${D}${bindir}
6 install -m 0755 ${TOOLS_SRC_DIR}/demos/ivshmem-demo ${D}${bindir}
7
8}
9
10FILES:${PN} = " \
11 ${bindir}/ivshmem-demo \
12"