summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-01-20 01:40:46 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-24 12:51:24 -0600
commitf5653ce0ae0675449315a3350859f8fc2c93f530 (patch)
tree62ab1d6cd6070d51da60257866b14ae32399e406 /meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
parent7cd8114bb0f646225fd4cafc3c699a73caa6dc0e (diff)
downloadmeta-ti-f5653ce0ae0675449315a3350859f8fc2c93f530.tar.gz
conf: machine: Use new J7 SoC names over specific board names
Now that we have SoC names, we can avoid adding features based on the board name. We expect folks to create their own boards based on these SoCs, and so using the TI made EVM board name everywhere adds extra churn when adding a new board. Plus it is more correct for most of these features as they depend on the SoC, not on the EVM board. One other thing we do here is to not use the generic "j7" name, the current and future J7 devices are far to feature diverse to group at this level. Grouping like that will lead to the wrong things getting enabled as new J7 SoCs are added. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb')
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb39
1 files changed, 18 insertions, 21 deletions
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 0447bafe..9a6da088 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -13,13 +13,10 @@ inherit deploy
13inherit update-alternatives 13inherit update-alternatives
14 14
15PLAT_SFX = "" 15PLAT_SFX = ""
16PLAT_SFX:j7 = "j721e" 16PLAT_SFX:j721e = "j721e"
17PLAT_SFX:j721e-hs-evm = "j721e" 17PLAT_SFX:j7200 = "j7200"
18PLAT_SFX:j7200-evm = "j7200" 18PLAT_SFX:j721s2 = "j721s2"
19PLAT_SFX:j7200-hs-evm = "j7200" 19PLAT_SFX:j784s4 = "j784s4"
20PLAT_SFX:j721s2-evm = "j721s2"
21PLAT_SFX:j721s2-hs-evm = "j721s2"
22PLAT_SFX:j784s4-evm = "j784s4"
23PLAT_SFX:am65xx = "am65xx" 20PLAT_SFX:am65xx = "am65xx"
24PLAT_SFX:am64xx = "am64xx" 21PLAT_SFX:am64xx = "am64xx"
25PLAT_SFX:am62xx = "am62xx" 22PLAT_SFX:am62xx = "am62xx"
@@ -50,7 +47,7 @@ LEGACY_DM_FW_DIR = "${D}${nonarch_base_libdir}/firmware/pdk-ipc/"
50 47
51DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" 48DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
52 49
53# J7 HS support 50# J721e HS support
54do_install:prepend:j721e-hs-evm() { 51do_install:prepend:j721e-hs-evm() {
55 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 52 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
56 ( cd ${RTOS_DM_FW_DIR}; \ 53 ( cd ${RTOS_DM_FW_DIR}; \
@@ -81,7 +78,7 @@ do_install:prepend:j721e-hs-evm() {
81 ) 78 )
82} 79}
83 80
84# J7 HS support 81# J7200 HS support
85do_install:prepend:j7200-hs-evm() { 82do_install:prepend:j7200-hs-evm() {
86 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 83 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
87 ( cd ${RTOS_DM_FW_DIR}; \ 84 ( cd ${RTOS_DM_FW_DIR}; \
@@ -102,7 +99,7 @@ do_install:prepend:j7200-hs-evm() {
102 ) 99 )
103} 100}
104 101
105# J7 HS support 102# J721s2 HS support
106do_install:prepend:j721s2-hs-evm() { 103do_install:prepend:j721s2-hs-evm() {
107 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 104 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
108 ( cd ${RTOS_DM_FW_DIR}; \ 105 ( cd ${RTOS_DM_FW_DIR}; \
@@ -149,7 +146,7 @@ do_install() {
149 : 146 :
150} 147}
151 148
152do_install:j7() { 149do_install:j721e() {
153 install -d ${LEGACY_IPC_FW_DIR} 150 install -d ${LEGACY_IPC_FW_DIR}
154 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 151 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
155 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 152 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
@@ -335,7 +332,7 @@ ALTERNATIVE:${PN}:j721e-hs-evm = "\
335 j7-c71_0-fw-sec \ 332 j7-c71_0-fw-sec \
336 " 333 "
337 334
338ALTERNATIVE:${PN}:j7 = "\ 335ALTERNATIVE:${PN}:j721e-evm = "\
339 j7-mcu-r5f0_0-fw \ 336 j7-mcu-r5f0_0-fw \
340 j7-mcu-r5f0_1-fw \ 337 j7-mcu-r5f0_1-fw \
341 j7-main-r5f0_0-fw \ 338 j7-main-r5f0_0-fw \
@@ -420,15 +417,15 @@ TARGET_MCU_M4FSS0_0:am64xx = "am64-mcu-m4f0_0-fw"
420TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw" 417TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw"
421TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw" 418TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw"
422 419
423TARGET_MCU_R5FSS0_0:j7 = "j7-mcu-r5f0_0-fw" 420TARGET_MCU_R5FSS0_0:j721e = "j7-mcu-r5f0_0-fw"
424TARGET_MCU_R5FSS0_1:j7 = "j7-mcu-r5f0_1-fw" 421TARGET_MCU_R5FSS0_1:j721e = "j7-mcu-r5f0_1-fw"
425TARGET_MAIN_R5FSS0_0:j7 = "j7-main-r5f0_0-fw" 422TARGET_MAIN_R5FSS0_0:j721e = "j7-main-r5f0_0-fw"
426TARGET_MAIN_R5FSS0_1:j7 = "j7-main-r5f0_1-fw" 423TARGET_MAIN_R5FSS0_1:j721e = "j7-main-r5f0_1-fw"
427TARGET_MAIN_R5FSS1_0:j7 = "j7-main-r5f1_0-fw" 424TARGET_MAIN_R5FSS1_0:j721e = "j7-main-r5f1_0-fw"
428TARGET_MAIN_R5FSS1_1:j7 = "j7-main-r5f1_1-fw" 425TARGET_MAIN_R5FSS1_1:j721e = "j7-main-r5f1_1-fw"
429TARGET_C66_0:j7 = "j7-c66_0-fw" 426TARGET_C66_0:j721e = "j7-c66_0-fw"
430TARGET_C66_1:j7 = "j7-c66_1-fw" 427TARGET_C66_1:j721e = "j7-c66_1-fw"
431TARGET_C7X_0:j7 = "j7-c71_0-fw" 428TARGET_C7X_0:j721e = "j7-c71_0-fw"
432 429
433TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec" 430TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec"
434TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec" 431TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec"