summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-02-15 13:33:45 -0600
committerRyan Eatmon <reatmon@ti.com>2023-03-01 09:24:28 -0600
commit5c1db20699c4bf7481948f1dc8a9fbf3018ca881 (patch)
treedb60345e3f649ba9a1f8120fc2be71874fbbe88d /meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
parentf82e11112395227c3dcc641024838de456fdb13b (diff)
downloadmeta-ti-5c1db20699c4bf7481948f1dc8a9fbf3018ca881.tar.gz
ti-rtos-firmware: Use new ti-secdev class to sign the images
Use ti-k3-secdev native package to provide secure-binary-image.sh script when it is not passed on as an environment variable. This fixes an issue with AM64xx which is always HS but should not require TI_SECURE_DEV_PKG when building for HS-FS or GP platforms. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb')
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 9a6da088..fddb5e2e 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -31,9 +31,7 @@ CLEANBROKEN = "1"
31PR = "${INC_PR}.0" 31PR = "${INC_PR}.0"
32 32
33# Secure Build 33# Secure Build
34DEPENDS += "openssl-native" 34inherit ti-secdev
35
36TI_SECURE_DEV_PKG ?= ""
37 35
38RTOS_ETH_FW_DIR = "${S}/ti-eth/${PLAT_SFX}" 36RTOS_ETH_FW_DIR = "${S}/ti-eth/${PLAT_SFX}"
39RTOS_DM_FW_DIR = "${S}/ti-dm/${PLAT_SFX}" 37RTOS_DM_FW_DIR = "${S}/ti-dm/${PLAT_SFX}"
@@ -49,7 +47,6 @@ DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
49 47
50# J721e HS support 48# J721e HS support
51do_install:prepend:j721e-hs-evm() { 49do_install:prepend:j721e-hs-evm() {
52 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
53 ( cd ${RTOS_DM_FW_DIR}; \ 50 ( cd ${RTOS_DM_FW_DIR}; \
54 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \ 51 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
55 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \ 52 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
@@ -80,7 +77,6 @@ do_install:prepend:j721e-hs-evm() {
80 77
81# J7200 HS support 78# J7200 HS support
82do_install:prepend:j7200-hs-evm() { 79do_install:prepend:j7200-hs-evm() {
83 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
84 ( cd ${RTOS_DM_FW_DIR}; \ 80 ( cd ${RTOS_DM_FW_DIR}; \
85 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \ 81 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
86 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \ 82 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
@@ -101,7 +97,6 @@ do_install:prepend:j7200-hs-evm() {
101 97
102# J721s2 HS support 98# J721s2 HS support
103do_install:prepend:j721s2-hs-evm() { 99do_install:prepend:j721s2-hs-evm() {
104 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
105 ( cd ${RTOS_DM_FW_DIR}; \ 100 ( cd ${RTOS_DM_FW_DIR}; \
106 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \ 101 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
107 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \ 102 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \