summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-05-01 19:22:50 +0000
committerRyan Eatmon <reatmon@ti.com>2023-05-03 08:40:08 -0500
commitd606b53903a1eb8b564b64994aeefb2d4defd3f9 (patch)
tree2963a51cfa74fd52a36dbd3ccafa86d1cfbc2306 /meta-ti-bsp/recipes-kernel/linux
parentc1d4a251720818edffe1faf50cd7363f0b7c7adb (diff)
downloadmeta-ti-d606b53903a1eb8b564b64994aeefb2d4defd3f9.tar.gz
linux-bb.org: add support for config fragments
* Add support for additional config fragments passed via semi-standard KERNEL_CONFIG_FRAGMENTS variable * Also don't build all DTBs, only those specified in the machine config Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb11
2 files changed, 5 insertions, 7 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig
new file mode 100644
index 00000000..a5de2e24
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig
@@ -0,0 +1 @@
use-kernel-config=bb.org_defconfig
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
index 43af4100..8604e028 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
@@ -7,6 +7,7 @@ COMPATIBLE_MACHINE = "beagle.*"
7 7
8inherit kernel 8inherit kernel
9 9
10require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/ti-kernel.inc 11require recipes-kernel/linux/ti-kernel.inc
11 12
12DEPENDS += "gmp-native libmpc-native" 13DEPENDS += "gmp-native libmpc-native"
@@ -26,13 +27,9 @@ PV:aarch64 = "5.10.162+git${SRCPV}"
26BRANCH:aarch64 = "v5.10.162-ti-arm64-r99" 27BRANCH:aarch64 = "v5.10.162-ti-arm64-r99"
27 28
28SRC_URI = "git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH} \ 29SRC_URI = "git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
29 file://init_disassemble_info-signature-changes-causes-compile-failures.patch" 30 file://defconfig \
31 file://init_disassemble_info-signature-changes-causes-compile-failures.patch \
32"
30 33
31SRC_URI:append:armv7a = " file://0001-defconfig-switch-default-kernel-compression-to-LZMA.patch" 34SRC_URI:append:armv7a = " file://0001-defconfig-switch-default-kernel-compression-to-LZMA.patch"
32 35
33DEFCONFIG_NAME = "bb.org_defconfig"
34KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
35
36kernel_do_compile:append() {
37 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
38}