summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-01-20 01:40:46 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-20 15:55:32 -0600
commit86d02e62e543e341b0bed9e9874e19bf04e29c39 (patch)
tree466d9a90bd4aab7a4aad7b3d9a8578107f8d85c3 /meta-ti-bsp/recipes-kernel/linux
parentad3d14240d10970de46043ae78d8de7eed6bf884 (diff)
downloadmeta-ti-86d02e62e543e341b0bed9e9874e19bf04e29c39.tar.gz
conf: machine: Use new J7 SoC names over specific board names
Now that we have SoC names, we can avoid adding features based on the board name. We expect folks to create their own boards based on these SoCs, and so using the TI made EVM board name everywhere adds extra churn when adding a new board. Plus it is more correct for most of these features as they depend on the SoC, not on the EVM board. One other thing we do here is to not use the generic "j7" name, the current and future J7 devices are far to feature diverse to group at this level. Grouping like that will lead to the wrong things getting enabled as new J7 SoCs are added. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 61dcbcd8..808a4766 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -25,7 +25,7 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw"
25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw" 25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw"
26 26
27# Add run-time dependency for Video Decoding firmware to the rootfs 27# Add run-time dependency for Video Decoding firmware to the rootfs
28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" 28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
29 29
30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs 30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" 31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index bf230dbc..67b28b2a 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -42,4 +42,4 @@ module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus" 42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus" 43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc" 44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
45KERNEL_MODULE_AUTOLOAD:append:j7 = " rpmsg_kdrv_switch" 45KERNEL_MODULE_AUTOLOAD:append:j721e = " rpmsg_kdrv_switch"