summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-03-29 10:34:50 -0500
committerRyan Eatmon <reatmon@ti.com>2023-03-31 09:25:29 -0500
commit2d5d741f9b30639ae3ab1f75a6ae547c007cb3f5 (patch)
tree9adbef19657321cfdf31f76cc5d5627db056c175 /meta-ti-bsp/recipes-kernel/linux
parent72cd51fa11b1f5cc9f252163792cdf495a5b1090 (diff)
downloadmeta-ti-2d5d741f9b30639ae3ab1f75a6ae547c007cb3f5.tar.gz
kernel-fitimage: Add signing of fitImage entries for 5.10 kernel
While we are mirgrating to kernel v6.1 and u-boot v2023.04, we want to keep kernel v5.10 and u-boot v2021.01 "working" for anyone looking at kirkstone. One of the items we are looking at changing is the signing of entries in the fitImage. To try and acheive a limited parity with dunfell while we work on the migration, this commit creates a class that implements the logic that was in dunfell and applies that class to the 5.10 kernel. This is a temporary patch that will be remvoed when we remove the 5.10 recipe down the road. This logic will not apply to the 6.1 kernel. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index 8bf92590..cc4c8843 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -3,6 +3,8 @@ SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6KERNEL_CLASSES += "${@bb.utils.contains('TFA_PLATFORM', 'k3', 'kernel-fitimage-ti-u-boot', '', d)}"
7
6inherit kernel 8inherit kernel
7 9
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"