summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-10-22 04:56:25 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-23 16:08:24 -0600
commit1cea5220ea9fde2ff7d055fae9512bb6e4f00a60 (patch)
treeadc1b0843d447c74dcdf9c98edcda9df11cdc47f /meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
parent92598343f31abf376328359315b5e1038a2861bc (diff)
downloadmeta-ti-1cea5220ea9fde2ff7d055fae9512bb6e4f00a60.tar.gz
linux-ti-next: add recipe for building linux-next
Required for daily test plans. Can be enabled in local.conf or <distro>.conf: PREFERRED_PROVIDER_virtual/kernel = "linux-ti-next" SRCREV:pn-linux-ti-next = "${AUTOREV}" Only uses in-tree defconfigs, does not support config fragments, builds and packages in-tree DTBs. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
new file mode 100644
index 00000000..e2908951
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
@@ -0,0 +1,43 @@
1SECTION = "kernel"
2SUMMARY = "Linux-next kernel for TI devices"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5
6inherit kernel
7
8require recipes-kernel/linux/ti-kernel.inc
9
10DEPENDS += "gmp-native libmpc-native"
11
12KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} ${EXTRA_DTC_ARGS}"
13
14S = "${WORKDIR}/git"
15
16# 6.1.0-rc1+ version
17SRCREV = "4d48f589d294ddc5e01d3b0dc7cecc55324c05ca"
18PV = "6.1.0-rc1+git${SRCPV}"
19
20SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master"
21
22def list_dtbs(dts_dir, dts_subdir):
23 import os
24 import fnmatch
25 matches = []
26
27 for root,dirnames,filenames in os.walk(os.path.join(dts_dir, dts_subdir)):
28 for filename in fnmatch.filter(filenames, '*.dtb'):
29 matches.append(os.path.join(dts_subdir, filename))
30 for filename in fnmatch.filter(filenames, '*.dtbo'):
31 matches.append(os.path.join(dts_subdir, filename))
32 return ' '.join(matches)
33
34DTS_SUBDIR = ""
35DTS_SUBDIR:k3 = "ti"
36KERNEL_DEVICETREE = "${@list_dtbs('${B}/arch/${ARCH}/boot/dts', '${DTS_SUBDIR}')}"
37DEFCONFIG_NAME = "multi_v7_defconfig"
38DEFCONFIG_NAME:k3 = "defconfig"
39KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
40
41kernel_do_compile:append() {
42 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
43}