summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-11-04 22:46:29 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-23 16:08:24 -0600
commit529bd52c5def63a02755640cb990c0f936c2b8a3 (patch)
treecf816ea74ca360ce9fa75a4ef412d98e0e306550 /meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
parentb8616f46278459f69ce3b13555030f855b36906c (diff)
downloadmeta-ti-529bd52c5def63a02755640cb990c0f936c2b8a3.tar.gz
linux-ti-mainline: unbreak devtool
devtool has a long-standing bug where it cannot handle references to ${WORKDIR} due to externalsrc: https://bugzilla.yoctoproject.org/show_bug.cgi?id=12677 linux-ti-mainline clones additional ti-upstream-tools repo alongside the kernel sources into ${WORKDIR}, which exposes this devtool bug. Work around the issue by moving ti-upstream-tools inside the kernel source tree, i.e. inside ${S} Reported-by: Radoslav Pesek <radoslav.pesek@microstep-mis.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index 0fe54cda..6c1b1825 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel
7 7
8DEFCONFIG_BUILDER = "${WORKDIR}/ti-upstream-tools/config/defconfig_builder.sh" 8DEFCONFIG_BUILDER = "${S}/ti-upstream-tools/config/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/kernel-rdepends.inc 10require recipes-kernel/linux/kernel-rdepends.inc
11require recipes-kernel/linux/ti-kernel.inc 11require recipes-kernel/linux/ti-kernel.inc
@@ -32,7 +32,7 @@ KERNEL_GIT_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.g
32KERNEL_GIT_PROTOCOL = "https" 32KERNEL_GIT_PROTOCOL = "https"
33SRC_URI += " \ 33SRC_URI += " \
34 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \ 34 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \
35 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=ti-upstream-tools \ 35 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=git/ti-upstream-tools \
36 file://defconfig \ 36 file://defconfig \
37" 37"
38 38
@@ -43,7 +43,7 @@ KERNEL_DEVICETREE = ""
43 43
44kernel_do_compile:append() { 44kernel_do_compile:append() {
45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
46 oe_runmake -C ${WORKDIR}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 46 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
47} 47}
48 48
49do_install:append() { 49do_install:append() {