summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-03-17 10:20:53 -0500
committerRyan Eatmon <reatmon@ti.com>2023-03-31 09:25:37 -0500
commit4baa0cbd9b2dfa54dba4461926d8d3e6d033c405 (patch)
tree1b5fa7fb9b0559ab4ce9314d38863b3ecef6ca8d /meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
parent2d5d741f9b30639ae3ab1f75a6ae547c007cb3f5 (diff)
downloadmeta-ti-4baa0cbd9b2dfa54dba4461926d8d3e6d033c405.tar.gz
linux-ti-*: Add filtering for which dtb/dtbo to include
We often carry more dtbs/dtbos in our kernel than we have upstreamed. The inclusion of all of the dtb/dtbo in the KERNEL_DEVICETREE has become problematic as we start testing the linux-next and 6.1 as part of our LTS migration. To address this issue we are adding in two step method for managing the KERNEL_DEVICETREE. Going forward we will only accept dtb/dtbo in KERNEL_DEVICETREE if it is available in upstream. This way we ensure that the variable is more accurate for whichever kernel you might be looking at. We have also added a new variable KERNEL_DEVICETREE_PREFIX which our kernel recipes will use to auto set KERNEL_DEVICETREE based on what files are in the kernel and not a fixed list in the conf files. Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index 6c1b1825..be278d73 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -39,34 +39,11 @@ SRC_URI += " \
39SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95" 39SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95"
40SRCREV_FORMAT = "linux" 40SRCREV_FORMAT = "linux"
41 41
42KERNEL_DEVICETREE = ""
43
44kernel_do_compile:append() { 42kernel_do_compile:append() {
45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 43 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
46 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 44 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
47} 45}
48 46
49do_install:append() {
50 for dtbf in `find arch/${ARCH}/boot/dts/ \( -name '*.dtb' -or -name '*.dtbo' \)`; do
51 dtb="$dtbf"
52 dtb_ext=${dtb##*.}
53 dtb_base_name=`basename $dtb .$dtb_ext`
54 dtb_path=`get_real_dtb_path_in_kernel "$dtb"`
55 install -m 0644 $dtbf ${D}/${KERNEL_IMAGEDEST}/$dtb_base_name.$dtb_ext
56 done
57}
58
59do_deploy:append() {
60 for dtbf in `find arch/${ARCH}/boot/dts/ \( -name '*.dtb' -or -name '*.dtbo' \) -printf '%P\n'`; do
61 dtb="$dtbf"
62 dtb_ext=${dtb##*.}
63 dtb_base_name=`basename $dtb .$dtb_ext`
64 dtb_dir=`dirname $dtb`
65 install -d ${DEPLOYDIR}
66 install -m 0644 ${D}/${KERNEL_IMAGEDEST}/$dtb_base_name.$dtb_ext ${DEPLOYDIR}/$dtb_base_name.$dtb_ext
67 done
68}
69
70do_shared_workdir:prepend() { 47do_shared_workdir:prepend() {
71 cd ${B} 48 cd ${B}
72 echo >> Module.symvers 49 echo >> Module.symvers