summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-04-11 16:52:38 -0500
committerRyan Eatmon <reatmon@ti.com>2023-04-12 07:54:04 -0500
commit00a4a5ed313bcbc774e5d7e04a86f86e8b6fba91 (patch)
treecbbfd5f2e705df27ae7fdbd3d6cdc0b13fe130df /meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
parentda6f02540f2405bcd77f1c8dfcbc6513d03dc1c3 (diff)
downloadmeta-ti-00a4a5ed313bcbc774e5d7e04a86f86e8b6fba91.tar.gz
linux-ti-mainline: Use upstream configs with upstream kernel
Mainline should test the mainline kernel as it is, not with out-of-tree changes like to the default configuration that one would get when using a stock distro. Use only upstream configuration. Signed-off-by: Andrew Davis <afd@ti.com> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index be278d73..7d948a85 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -5,8 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel
7 7
8DEFCONFIG_BUILDER = "${S}/ti-upstream-tools/config/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/kernel-rdepends.inc 8require recipes-kernel/linux/kernel-rdepends.inc
11require recipes-kernel/linux/ti-kernel.inc 9require recipes-kernel/linux/ti-kernel.inc
12 10
@@ -33,12 +31,16 @@ KERNEL_GIT_PROTOCOL = "https"
33SRC_URI += " \ 31SRC_URI += " \
34 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \ 32 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \
35 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=git/ti-upstream-tools \ 33 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=git/ti-upstream-tools \
36 file://defconfig \
37" 34"
38 35
39SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95" 36SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95"
40SRCREV_FORMAT = "linux" 37SRCREV_FORMAT = "linux"
41 38
39DEFCONFIG_NAME = "multi_v7_defconfig"
40DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig"
41DEFCONFIG_NAME:k3 = "defconfig"
42KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
43
42kernel_do_compile:append() { 44kernel_do_compile:append() {
43 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
44 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} 46 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}