summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/vpe-tests
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/vpe-tests
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/vpe-tests')
-rw-r--r--meta-ti-bsp/recipes-bsp/vpe-tests/vpe-tests_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/vpe-tests/vpe-tests_git.bb b/meta-ti-bsp/recipes-bsp/vpe-tests/vpe-tests_git.bb
new file mode 100644
index 00000000..92c425b1
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/vpe-tests/vpe-tests_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "VPE test program"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa"
5
6DEPENDS = "virtual/kernel vpdma-fw"
7
8PR = "r3"
9
10COMPATIBLE_MACHINE = "dra7xx"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca"
15BRANCH ?= "master"
16
17SRC_URI = "git://git.ti.com/vpe_tests/vpe_tests.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21FLOATABI = "${@bb.utils.contains("TUNE_FEATURES", "vfp", bb.utils.contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
22
23# The test application needs additional include headers from the kernel
24EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${FLOATABI}" KDIR="${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"'
25
26do_install() {
27 oe_runmake DESTDIR="${D}" install
28 rm -rf ${D}${base_libdir}/firmware/vpdma-*.bin
29 rmdir -p ${D}${base_libdir}/firmware || true
30}