summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-01-26 01:43:11 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-31 14:44:38 -0600
commitf843fa1914896358911b52eba7052ba1996a6919 (patch)
tree39069444281a91514eb60bb284fa8f0532396bba /meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
parent0b3fa09a5f0bddcedeadc90e694aa098b7fd1733 (diff)
downloadmeta-ti-f843fa1914896358911b52eba7052ba1996a6919.tar.gz
meta-ti-bsp: add BeagleBone AI-64 support
BeagleBone AI-64 (https://beagleboard.org/ai-64) uses Texas Instruments Jacinto TDA4VM/J721e SoC. Officially BeagleBone AI-64 supports Debian Linux and builds its BSP on top of meta-ti and TI SDK, but adds custom DTBs and DTBO overlays, plus integrates other drivers and features. Let's add corresponding recipes for beagleboard.org kernel and u-boot along with the BeagleBone AI-64 machine config. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 8e88b58b..578f56b8 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -11,6 +11,7 @@ DEPENDS:remove:am65xx-hs-evm-k3r5-sr2 = "virtual/bootloader"
11DEPENDS:remove:j721e-evm-k3r5 = "virtual/bootloader" 11DEPENDS:remove:j721e-evm-k3r5 = "virtual/bootloader"
12DEPENDS:remove:j721e-hs-evm-k3r5 = "virtual/bootloader" 12DEPENDS:remove:j721e-hs-evm-k3r5 = "virtual/bootloader"
13DEPENDS:remove:j721e-hs-evm-k3r5-sr1-1 = "virtual/bootloader" 13DEPENDS:remove:j721e-hs-evm-k3r5-sr1-1 = "virtual/bootloader"
14DEPENDS:remove:beaglebone-ai64-k3r5 = "virtual/bootloader"
14DEPENDS:append = "${@ '' if d.getVar('TI_SECURE_DEV_PKG_K3') else ' ti-k3-secdev-native' }" 15DEPENDS:append = "${@ '' if d.getVar('TI_SECURE_DEV_PKG_K3') else ' ti-k3-secdev-native' }"
15 16
16CLEANBROKEN = "1" 17CLEANBROKEN = "1"
@@ -33,6 +34,7 @@ SYSFW_PREFIX = "sci"
33SYSFW_PREFIX:j721e-evm-k3r5 = "fs" 34SYSFW_PREFIX:j721e-evm-k3r5 = "fs"
34SYSFW_PREFIX:j721e-hs-evm-k3r5 = "fs" 35SYSFW_PREFIX:j721e-hs-evm-k3r5 = "fs"
35SYSFW_PREFIX:j721e-hs-evm-k3r5-sr1-1 = "fs" 36SYSFW_PREFIX:j721e-hs-evm-k3r5-sr1-1 = "fs"
37SYSFW_PREFIX:beaglebone-ai64-k3r5 = "fs"
36SYSFW_PREFIX:j7200-evm-k3r5 = "fs" 38SYSFW_PREFIX:j7200-evm-k3r5 = "fs"
37SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs" 39SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX:j721s2-evm-k3r5 = "fs" 40SYSFW_PREFIX:j721s2-evm-k3r5 = "fs"
@@ -70,6 +72,7 @@ EXTRA_OEMAKE:remove:am65xx-hs-evm-k3r5-sr2 = "SBL="${STAGING_DIR_HOST}/boot/u-bo
70EXTRA_OEMAKE:remove:j721e-evm-k3r5 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 72EXTRA_OEMAKE:remove:j721e-evm-k3r5 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
71EXTRA_OEMAKE:remove:j721e-hs-evm-k3r5 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 73EXTRA_OEMAKE:remove:j721e-hs-evm-k3r5 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
72EXTRA_OEMAKE:remove:j721e-hs-evm-k3r5-sr1-1 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 74EXTRA_OEMAKE:remove:j721e-hs-evm-k3r5-sr1-1 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
75EXTRA_OEMAKE:remove:beaglebone-ai64-k3r5 = "SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
73 76
74do_compile() { 77do_compile() {
75 cd ${WORKDIR}/imggen/ 78 cd ${WORKDIR}/imggen/