summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/prusw-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/prusw-fw
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/prusw-fw')
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb34
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb31
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..2d0d3f9e
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "PRU Ethernet Switch firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = " \
17 am65x-sr2-pru0-prusw-fw.elf \
18 am65x-sr2-pru1-prusw-fw.elf \
19 am65x-sr2-rtu0-prusw-fw.elf \
20 am65x-sr2-rtu1-prusw-fw.elf \
21 am65x-sr2-txpru0-prusw-fw.elf \
22 am65x-sr2-txpru1-prusw-fw.elf \
23"
24
25do_install() {
26 install -d ${D}${base_libdir}/firmware/ti-pruss
27 for f in ${TARGET}; do
28 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
29 done
30}
31
32FILES:${PN} = "${base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
new file mode 100644
index 00000000..3ded0dc4
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
@@ -0,0 +1,31 @@
1SUMMARY = "PRU Switch firmware for AM57xx, AM437x and AM335x"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PR = "${INC_PR}.0"
6
7CLEANBROKEN = "1"
8
9COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13S = "${WORKDIR}/git"
14
15TARGET = ""
16TARGET:ti33x = "am335x-pru0-prusw-fw.elf am335x-pru1-prusw-fw.elf"
17TARGET:ti43x = "am437x-pru0-prusw-fw.elf am437x-pru1-prusw-fw.elf"
18TARGET:am57xx-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
19TARGET:am57xx-hs-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
20
21do_install() {
22 install -d ${D}${base_libdir}/firmware/ti-pruss
23 for f in ${TARGET}; do
24 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
25 done
26}
27
28
29FILES:${PN} = "${base_libdir}/firmware"
30
31INSANE_SKIP:${PN} = "arch"