summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/pruprp-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/pruprp-fw
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/pruprp-fw')
-rw-r--r--meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
new file mode 100644
index 00000000..707640b4
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
@@ -0,0 +1,32 @@
1SUMMARY = "PRU PRP firmware for AM335x/AM437x/AM57xx"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PE = "1"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = ""
17TARGET:ti33x = "am335x-pru0-pruprp-fw.elf am335x-pru1-pruprp-fw.elf"
18TARGET:ti43x = "am437x-pru0-pruprp-fw.elf am437x-pru1-pruprp-fw.elf"
19TARGET:am57xx-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
20TARGET:am57xx-hs-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
21
22
23do_install() {
24 install -d ${D}${base_libdir}/firmware/ti-pruss
25 for f in ${TARGET}; do
26 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
27 done
28}
29
30FILES:${PN} = "${base_libdir}/firmware"
31
32INSANE_SKIP:${PN} = "arch"