summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-10-16 21:29:49 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-16 21:34:07 -0500
commitc3b08caa9b63ea287963c9d02a448e00b3bb7653 (patch)
tree8b22a621c0fb5d80c85a5fab966f17073f633cd8 /meta-ti-bsp/recipes-bsp/powervr-drivers
parent01835f50187b46e079e8453833de26f1df5a7065 (diff)
downloadmeta-ti-c3b08caa9b63ea287963c9d02a448e00b3bb7653.tar.gz
ti-sgx-ddk-*: version bump to support kirkstone
Bump ti-sgx-ddk-um and ti-sgx-ddk-km to the new branch for Kirkstone and mesa independent builds. This also sets up SGX to use the latest mesa revision rogue uses. Changelog: - IMG Support has officially ended. This repo will not be getting regular updates after this unless things are really broken. - The Mesa patches which were previously being relicensed internally were opened and combined with the unofficial rogue efforts on freedesktop. - Toolchains were upgraded and multiple warnings and issues were addressed. Hardware recoveries work now, but there are still some longstanding issues with SGX that remain to be addressed if further resources are set aside for that. - We moved to an lws-generic build target to avoid rebuilding external components. As such, these external components must be patched as needed. Libdrm is an example of this and the required patches can be found in meta-ti. Known bugs: - Buffer allocations under Weston may misbehave - GLSL macro redefinitions will cause errors regardless of whether or not they are identical Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/powervr-drivers')
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb27
1 files changed, 12 insertions, 15 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
index bf4fa98a..ca28ae76 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs" 1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux" 2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux"
3LICENSE = "MIT | GPL-2.0-only" 3LICENSE = "MIT | GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12" 4LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
5 5
6inherit module 6inherit module
7 7
@@ -16,33 +16,30 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
16 16
17DEPENDS = "virtual/kernel" 17DEPENDS = "virtual/kernel"
18 18
19BRANCH = "ti-img-sgx/${PV}/k5.10" 19BRANCH = "${PV}/mesa/k6.1"
20 20
21SRC_URI = "git://git.ti.com/git/graphics/omap5-sgx-ddk-linux.git;protocol=https;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/git/graphics/omap5-sgx-ddk-linux.git;protocol=https;branch=${BRANCH}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25SRCREV = "eda7780bfd5277e16913c9bc0b0e6892b4e79063" 25SRCREV = "2cb2c9609b7740cb2c348e669a96f26e1cc858da"
26 26
27TARGET_PRODUCT:omap-a15 = "jacinto6evm" 27TARGET_PRODUCT:omap-a15 = "ti572x_linux"
28TARGET_PRODUCT:ti33x = "ti335x" 28TARGET_PRODUCT:ti33x = "ti335x_linux"
29TARGET_PRODUCT:ti43x = "ti437x" 29TARGET_PRODUCT:ti43x = "ti437x_linux"
30TARGET_PRODUCT:am65xx = "ti654x" 30TARGET_PRODUCT:am65xx = "ti654x_linux"
31PVR_BUILD = "release" 31PVR_BUILD = "release"
32PVR_WS = "nulldrmws" 32PVR_WS = "lws-generic"
33 33
34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}' 34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} \
35 35WINDOW_SYSTEM=${PVR_WS} PVR_BUILD_DIR=${TARGET_PRODUCT}'
36do_compile:prepend() {
37 cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux
38}
39 36
40do_install() { 37do_install() {
41 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_${PVR_WS}_${PVR_BUILD}/target_armhf/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install 38 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasiacon/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_armhf/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
42} 39}
43 40
44do_install:am65xx() { 41do_install:am65xx() {
45 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install 42 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasiacon/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
46} 43}
47 44
48RRECOMMENDS:${PN} += "ti-sgx-ddk-um" 45RRECOMMENDS:${PN} += "ti-sgx-ddk-um"